Help with building your Speeduino, installing it, getting it to run etc.
User avatar
By bugster_de
#67959
Hi folks,

I hope anybody has an idea on this; I'm stuck

I'm running a DIY-EFI Core4 on my 1978 VW Campervan (2 Liter aircooled Boxer engine). Injection mechanics is all stock VW, Ignition and timing wheel is basic distributor with a single coil. The distributer has a Hall Effect Sensor included with even distribution (it's actually from a 1600i Beetle), My MSQ is attached. FW version is 2024-02

Effect: Above ~1.000 rpm the ignition angle on the engine is twice the value of the MAP. So say I do have 20 degrees BTDC in TunerStudio in the Map, I can see 40° BTDC with the timing light . When setting 30 degrees in the MAP, in reality it is 60 degrees with the timing light, which is of course well beyond healthy.

For the time being if have hence divided all map values by 2. So if I want to have 20 degrees on the engine, I'll set the map to 10 degrees. With that, Engines is running smooth with super stable ignition timing

Any idea what's going on here?
Attachments
(92.12 KiB) Downloaded 48 times
By LPG2CV
#67963
Please post a log with tune it was taken with.

Edit

Totally random thought here. Are you wired to Crank input, or Cam? Though you may think Cam, I suspect it should be Crank.

I could be totally off here. :D
User avatar
By bugster_de
#67977
LPG2CV wrote:Please post a log with tune it was taken with.
please find attached
LPG2CV wrote: Totally random thought here. Are you wired to Crank input, or Cam? Though you may think Cam, I suspect it should be Crank.

I could be totally off here. :D
I replaced the stock distributor with the Beetle one. So this is running on camshaft speed
in the MSQ as attached, you can see the setting is set to basic distributor. I would assume, Speeduino is aware about a basic distributor running at camshaft speed.

EDIT: or do you mean I wired the Hall signal to RPM1 instead of RPM2? If so, I have to check but then I would assume the engine speed as seen by speeduino is only half of reality, which isn't the case. The engine speed of speeduino is the same as the tacho and also the same as my ignition timing light shows (it is also showing RPM and dwell)
Attachments
(1.66 MiB) Downloaded 33 times
User avatar
By bugster_de
#67984
LPG2CV wrote: Mon Apr 15, 2024 7:50 pm Are you wired to Crank input, or Cam? Though you may think Cam, I suspect it should be Crank.
I just checked and the Hall sensor is wired to RPM1 input.

As said I'm using DIY-EFI CORE4 board with a self-designed break-out board inside the ECU so the speeduino fits the original ECU housing and connector. On this breakout board, the HAL pin is routed to RPM1. RPM2 is wired to ground.
So it isn't easy (read: impossible) for me to rewire in case this wiring is wrong. However in init.cpp, I can swap the RPM1 and RPM2 pins over in software, recompile and download. Correct?
By LPG2CV
#67985
As I said, random thought :)

The log suggests the advance is correct from the table. I doubt the engine would actually run with 60* of advance.

This suggests to me that the doubling of advance is in the timing light.

For clarity, we tend to refer to map as the map sensor. :)
User avatar
By bugster_de
#67986
LPG2CV wrote: Tue Apr 16, 2024 9:28 am The log suggests the advance is correct from the table. I doubt the engine would actually run with 60* of advance.
as said above: when programming 10° in the table, it is actually 20° on the engine. The real reading on the engine from the timing light can't be seen in the log though. Hence of course the log shows the correct values.

There's nothing wrong with my timing light. I do own and use this one since a couple of years and it works fine. It is Speeduino giving double timings. I also do own a second timing light and can use this to test for peace of mind.
User avatar
By jonbill
#67988
Did you previously use any earlier releases? i have a feeling there may have been some work on basic distributor in 202402
SPEEDUINO installed

What is ATV? Your local govt test scheme? I think […]

Hello All, Looking at ordering parts. Digikey hav[…]

Thanks for the reply and explication. The ha[…]

BMW E23 M30B28

I have used 14point7 products successfully. Note […]

Still can't find what you're looking for?