For anything related to the 'official' Speeduino boards (Eg v0.3, v0.4 etc)
User avatar
By jonbill
I've only built for mega with vs code/platform io. I believe that is also the preferred toolchain for teensy. there's much more to it than compiling speeduino.ino.
have you tried platform io? and building without modifications first?
By MadScientistDad
So last night I used platform io to try and get this working. I wasn't able to but I was able to build and upload. The problem is still that TS doesn't see the ECU on the COM port. Using Platform IO, I built and uploaded from the Teensy35 task. It uploaded fine with no errors. Nothing. I tried changing the Signature on the PlatformIO.ini file. Nothing. I think it must have something to do with the fw file loaded on the ECU vs the .ini file that TS uses but I can't seem to figure it out. Any ideas?
By dazq
If TS doesn't see the teensy com port then it has nothing to do with an ini mismatch.
If TS is connecting it will show a ini mismatch error if there is one.

If TS won't find or connect t the com port it is likely something is holding the port open , thus preventing TS from being able to use it.

I must be honest I use teensy and mega based speedy and only compile and upload using the Arduino IDE and have never had an issue with the upload or compile( as a thought all the code changes I have ever submitted to speedy to Date were written on the Arduino IDE.)
By MadScientistDad
Hey Dazq,

So, TS can see the COM port(COM10), it just doesn't see anything on the COM port. Even when I hit detect on the firmware page in project properties, it doesn't find anything. I close out of Arduino and VScode before I open TS as well just to make sure that one of them isn't holding it open. But, like I said previously, if I use speedy loader it pops right up no problem. One thing I did notice is, when I compile/upload manually, the teesny programmer shows the file as firmware.hex but when I do it with speedy loader it says 202202-teensy35.hex. Does that mean anything?
By dazq
You can do a simple response test using the serial monitor in the Arduino IDE.
Enter s or q and you will get the firmware version as a response . This is the first thing TS looks for. If you don't get that in the serial monitor then TS has no hope.
There is also a Comms log in TS but the above is a quick simple test the speedy is actually talking(IE the firmware is running)
By MadScientistDad
So Im still having the same problem. I tried to enter an S and a Q but got no response. I checked it using speedy loader and it gave me "speeduino 202202". But, to verify I was compiling correctly (or at least I think I am), I compiled it on an Arduino Mega and it works just fine. TS picked it right up and I got the firmware version from the IDE serial monitor. So that leads me to think that my IDE isn't working correctly with the teensy. I am going to try and uninstall the IDE and reinstall it and Teensyduino and see if that works. Any other ideas?

*update- Re-install didn't help
By MadScientistDad
Hey Jan,

Yes I have tried that. But, here is what I have figured out. I tried loading it on a Teensy 4.1 and guess what...worked just fine. So at this point, I think I can narrow it down to the teensy 3.5. Is there anyway to completely wipe a teensy and set it back to its factory settings?

Quick update: I had to clear the EEPROM on the Teensy to get it to work. hold the reset button for 15 seconds (use a timer) to reset. Thanks for all the help guys.
Anyone with ESP32C3?

Look how cute that little fella is. Now I just nee[…]

Fuel Pump for a 150cc

I have used an inlet adapter fitting to convert a[…]

Honda's Alternator Control is just a PWM based o[…]

For Peugeot Valeo throttle valve to fix throttle[…]

Still can't find what you're looking for?