For discussion of Speeduino compatible boards designed / built by other members of the forum and for guidance around making such a board
By ME124
#67649
Gushito wrote: Tue Mar 26, 2024 1:37 am
ME124 wrote: Tue Mar 19, 2024 2:20 pm Hi Chris,

sorry for my late reply.
I tried using the base tune like you said.
I also reflashed the firmware a couple of times and tried different versions.

But my problems still are the same.
MAP is without response.
If I change the output pin of my MAP sensor for example to TPS, I get a response to the change in pressure.

The second problem is:
My oxygen sensor is heating up normally, but there's no responsen in the lambda value in Tunerstudio.

Are there some additional settings I missed?
Hello ME124
You need to connect the map sensor to the internal baro pin. I had the same situation and was able to resolve the issue.


Chris, your box, it's the best! I placed an order with jlcpcb and I'm doing tests on my car, I need to add a 4-wire stepper motor, I'm making a parallel PCB with the DRV8825 driver but I don't know if I'll be able to get it to work!
I also have to solve the problem with reading lambda, I can't read anything, I enabled the configuration on pin 49, like in your screenshot, but nothing happens. I am using 202310 fw and v.0.1.2 for the probe.
I also built an oled screen to connect to rx3 and tx3, but nothing happens either, I enabled serial mode in tunerstudio but it doesn't work, maybe I need to readjust the assigned pins? Use of d0 and d1 on nano arduino to oled board.
Can you help me with any of these issues?
Thank you!!
So the issue with MAP is a firmware or user problem? :D

As I said before: The probe is heating, so the CJ125 should work okay, right?

For me it looks like the lambda signal is not getting through.
Is there a way to debug the situation?
By ME124
#67697
I've finally figured out why MAP and Lambda weren't working.

Looking at the schematics, MAP becomes AD_MAP and is routed to (ADC5/TMS)PF5 (Pin 92).

In the file init.cpp starting at line 2169 the pin layout is defined.
In line 2187 the internal MAP sensor is defined as pinMAP = A7, which in the schematics is the AD_BARO Pin of the optional MPXH6400AC6T1 sensor.

After setting pinMAP = A5 and pinBaro = A7 it works.

Before changing init.cpp I tried defining the EMAP sensor within Tunerstudio but without success.
Maybe I'm missing something here.

To make Lambda work I had to define the calibration curve of the sensor under Tools>Calibrate AFR Sensor as defined here:
https://github.com/oelprinz-org/Blitzbo ... mbdaCtrl.h

/* Lambda Outputs are defined as follow:
*
* 0.5V = 0,68 Lambda = 10 AFR (Gasoline)
* 4,5V = 1,36 Lambda = 20 AFR (Gasoline)
*
* Internal Lambda is used in a range from 68..136
*
**/

I'm looking forward to installing the ECU in my Yamaha.
Thanks for all your work designing this awesome ECU.

One more thing:
What is the reason for starting with the .msq provided in GitHub?
What are the differences compared to the base tune of SpeedyLoader?
By purplelightning
#68120
I'm probably missing a fundamental understanding here.... But how are the MEGA and AFR controller are actually programmed via hardware? Do I program\flash them on another board and transfer them to the Blitzbox board?
User avatar
By chaoschris
#68124
nope, both MCUs were programmed direct on the board. You need another cheap tool for this. Any USBasp, TinyISP, Arduino in ISP-Mode or whatever for it to program it and set the fuses.
Software is avrdude (commandline) or AVRDUDESS (GUI).
You can get any of these tools everywhere and they are really cheap, beginning at 2 Dollars and up.
Of course you can use any of the official hardware tools from Atmel, but this isn't necessary.
For example I am happy with these cheap USBasp clones, they work flawlessly for any of my needs ....
User avatar
By chaoschris
#68125
ME124 wrote: Thu Mar 28, 2024 8:14 pm One more thing:
What is the reason for starting with the .msq provided in GitHub?
What are the differences compared to the base tune of SpeedyLoader?
There are some special settings in it, for example the programmable output to enable the lambda controller.
You should also start in firmware 202402(at this moment) with this msq. Since 202402 the Blitzbox is officially integrated in the firmware, but the msq which you can download (with speedyloader) was the older msq from the last firmware in 2023. And there were some minor errors in it using it with the newer 202402 firmware. I am not sure this is already fixed or not at this time
By purplelightning
#68135
runesm wrote: Mon Sep 25, 2023 6:22 pm
Connect blitzbox and arduino with isp with jumperwires. Connect arduino with isp sketch to computer, in arduino IDE select Mega 2560 board. In one of the drop down menu's, select burn bootloader. Wait for succesful finish.
I think this is where I am stuck.... where do the jumper wires go between the ISP and the chip on the Biltzbox board?

/edit OK, I was way over thinking this..... Looks like that's what the header on the board is for. I'll leave this here for anyone else that might be at my knowledge level.

What case designs exist at the moment?
By Hich
#68248
Hi,
Thanks a lot for the nice work!

Some time back I have converted my 200cc LML scooter with a Chinese MotoEFI kit to fuel injection. However, I finally got stuck as the delivered ECU could not be programmed as expected and there was no access to the Firmware.
So I am now trying to replace the MotoEFI ECU with Blitzbox... I have ordered, soldered and programmed the board and am now trying to wire-up the components. I am currently wondering if the IGN pin can be directly connected to the Ignition coil, or do I need a CDI unit in between? Also the WB Lamda Pin 4 is not on the connector, does this directly connect to 12V+?

Thanks a lot Karsten
User avatar
By chaoschris
#68250
Hich wrote: Thu May 02, 2024 7:55 am I am currently wondering if the IGN pin can be directly connected to the Ignition coil, or do I need a CDI unit in between? Also the WB Lamda Pin 4 is not on the connector, does this directly connect to 12V+?
Hi Karsten,
the ignition output only serves for ignition coils with integrated drivers. So if you plan to drive a dumb coil without integrated driver you must use an external driver or switch the coil to a more modern model with integrated driver.

Due to the limited numbers of connection pins the power supply for the lambda sonde must be wired directly and not via Blitzbox. You can also switch this supply with the fuel pump relay as the lambda sonde should be only heated when the engine is running.

Best regards,
Chris
By Hich
#68253
Thanks a lot for the quick feedback:)

I have another question: The throttle body with IAT, MAP, Idle Sol, TPS in the existing system has a supply voltage of 12V, so I believe at least TPS will return something 0...12V. Is this ok to feed into the TPS pin directly or do I need to ensure this to be 0..5V?
Thanks a lot and best regards Karsten
  • 1
  • 16
  • 17
  • 18
  • 19
  • 20
  • 21

I saw this suggested on GitHub. I've used programm[…]

BMW E23 M30B28

Ignore my previous posts, I'm an idiot. Turns out […]

He's quite prolific with respect to video and elec[…]

I’m thinking it’s the voltage regulato[…]

Still can't find what you're looking for?