For discussion of Speeduino compatible boards designed / built by other members of the forum and for guidance around making such a board
By diablospeed
In principle you are right, but it's a M52 PNP planned to work with M52. The designer, Pazi, writes firmware to make it work then i dont' understand why we would change wiring after or is it not PNP. I think, if it was necessary to modify something Pazi writes on his document, like the rest of assembly instructions.
User avatar
By pazi88
diablospeed wrote: Fri Aug 12, 2022 10:58 am I had a Speeduino MS41 REV3.0B made by JLC PCB and i use M54 cam sensor.
The problem is that i can't get the engine to run properly, i tested a lot of configuration in tuner studio (engine constants, trigger setup...), and i read all your documents but the engine does not run well. It crank and start but, opération is erratic.
I saw the last Firmware on Github 202207 and i used it. The engine runs on its 6 cylinders but not perfectly.
I searched a lot for solutions, but i'don't find where is the problem. I tried with Arduino IDE, manual compiling firmware (global.h: INJ-6 IGNI-3) , No result.
I ended up realizing by watching led flashing that the engine is out of sync. Injection séquence is currently: 123456 whereas it should be 153624 ? like ignition ?
The ignition pairing is weird too, currently : 1-4, 2-5, 3-6 .
It'a firmware problem ? or what else ?


Yes that's normal. You are now mixing up output numbers and cylinder numbers. Don't worry. It's classic mistake to make. Speeduino fires injectors and coils in numeric order. Like basically any other aftermarket ecu does. Firing order in bmw m5x is 1,5,3,6,2,4 by cylinder number, so the inj/ing output 1 is wired to cyl 1. Inj/ing output 2 is wired to cyl 5 and so on:

1 - > 1
2 - > 5
3 - > 3
4 - > 6
5 - > 2
6 - > 4
For wasted spark/batch fire the cylinder pairs are 1-6, 2-5 and 3-4. From that previous, you can see that in order to achieve that, you need to pair output numbers. 1-4, 2-5 and 3-6.

If you are using the pre-compiled FW from github or just modified the code for 6inj and 3ign outputs, it will run fine when hardware itself is ok.
By diablospeed
Thanks Pazi for your answer. So i think i have a hardware problem. Are JLC PCB components reliable ? The rest of the components have been purchased from RS.
A video to see better.
I tried unplungging coil one by one, no result.
I mesured AFR bank by bank, no difference, I am very rich 10:1, if i remove fuel, engine shuts down.
I tested 2 MEGA2560, copy and original, no différence.
M54 cam sensor tested on M54B30, is ok.

The only CMS component welded by myself is U6, it's not easy, i don't know if this components can cause the problem.
All transistors were bought on RadioSpare.

I don't now where to look and how....
By Zsoltee
Hey guys,

I have built a Rev2.2 version of this ECU for an M52 engine. I have installed the DIY EFI TinyWB controller on the board and im using an original Bosch LSU4.9 with it. I have a problem with the AFR reading on the car. After start of the engine it seems its working, it showing values and jumps all around the place, but after some time its stuck at 15.9, sometimes its going to 15.6, but its really stable and it seems its just stuck. We have tried to place it inside the header where the original one is located and we also tried to place it after the transmission, because we thought its not working good because it only sees three cylinders. But its not the case, in every location same behavior. The heating of it is working and it gets super hot even in the place after the transmission, so i think it should work, but it doesnt.

How can i diagnose the problem with normal everyday tools? Do you have any idea what can be wrong? I have selected the TinyWB in the AFR Calibration menu, so it should work fine.

Thanks for your help in advance.

Best Regards,
By diablospeed
I tried another PCB on the 5 that i have, problem is still there. The problem is present in steady state, when I press the accelerator, the acceleration is good. In the first video, I don't know why the rev limiter is at 1.5 krpm, but it doesn't change anything when I put it at 6.5k. Looks like an ignition problem, but i'm not sure.
By any chance, someone tested version 3.0B ? because when I read the forum, I believe to be the first.
I'm a little disappointed, I spent a lot of time trying various configurations, without results and not many people to help on the forum. :( :(
Is it possible that a bad configuration on TS gives that ?
By Zsoltee
What we have found out in the meantime is that the Wideband probe is fully working. So its measuring the AFR right in a different car with VEMS. So maybe i have some issue with the settings or the calibration of the AFR gauge? Maybe issue with the TinyWB. :?
User avatar
I would test the WBO2 controller and sensor first, in order to determine if it is in that unit or downstream (in the pcb, or software). If you do not know how to proceed, I would suggest keying-on while reading the signal output voltage, relative to the TS gauge indication. They should relatively match between signal voltage and gauge reading (V+ = Gauge+, etc). If not, I would remove the WBO2 controller and test separately for a change in function.

The clues are if the output signal flat-lines or deviates from the gauge or not. If so, then dig further downstream. If not, then the symptom is in the controller or sensor. That's the concept anyway, looking for clues to where the odd behavior begins (WBO2 or Speeduino).
  • 1
  • 26
  • 27
  • 28
  • 29
  • 30
  • 35
SPEEDUINO installed

What is ATV? Your local govt test scheme? I think […]

Hello All, Looking at ordering parts. Digikey hav[…]

Thanks for the reply and explication. The ha[…]

BMW E23 M30B28

I have used 14point7 products successfully. Note […]

Still can't find what you're looking for?