Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
Help with building your Speeduino, installing it, getting it to run etc.
User avatar
By PSIG
#51657
Image

Correction % = New_ms / Baseline_ms * 100

So, pick a dead time near your average running voltage as the baseline (100%). Let's say that's 14V and 0.8ms dead time. You would enter 100 at 14V in your corrections table.

Now you test at 12V and find 1.1ms. Use the formula above:

1.1 / 0.8 * 100 = 137.5%

Round and enter 138 in your 12V correction cell. Repeat for other lower and higher voltages. I typically enter a range of 8V to 16V values for "12V" vehicles. 8-)

Note — you can pick any voltage for your baseline, but I like to see minimum corrections when all is "normal", so those are the baselines I use most often. Just my thing.
By Torslund
#52002
What went wrong? On bench I had inj1 inj4 fire together, 2 and 3 together also. On engine all fires at same time. So running very rich. On scope I had 1 and 4 on first rev and 2 and 3 on next rev = engine cycle. But now I can make that happened?
By Torslund
#52018
Measuring on engine and dual wheel trigs is there. But I can't make speedy squirt the way it did before. 4 cyl, 4 injectors, 2 squirts/cycle, it's as it don't let me take control over the squirts. Has AI take over?
By Torslund
#52019
Made some measurements and it's so that all injectors channels fires at same time. Can speedy sketch be corrupt or mega memory? So changes does not change channel timing.
By Torslund
#52106
I believe more and more on a software issue. Speedy doesn't respond correct to changes from TS. For days I could not make it fire sequentially and suddenly it did. But did not respond correct to changes from that. And I can't see any pattern in that. Is the software tested with anything else then same set up all time on same bench with "same engine"?
By Torslund
#52108
Next time I opened I got this fault message. Should not be, so connection error, bad TS or bad speedy? If data is different in TS and speedy, so maybe everything I send can be corrupt.
Attachments
IMG_20210728_173140.jpg
IMG_20210728_173140.jpg (182.43 KiB) Viewed 635 times

If you haven't already bought the TBs yet, you co[…]

Can't help with IAC. Your intake runner. Use the […]

After weeks of search. here is the result, it is[…]

Range Rover Classic Speeduino Project

Just a hint for your engine: The latest engine bui[…]

Still can't find what you're looking for?