Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
For discussion of Speeduino compatible boards designed / built by other members of the forum and for guidance around making such a board
By rungo
#51123
My.Yeremenko wrote:
Wed Jun 03, 2020 8:19 am
this is how it ended up
 
Image
Image Image Image Image Image Image
How did the wiring end up with these ?
both vag cop coil grounds to cylinderhead ? or did you route other one back using the original grounding wires back to euc ?, did you remove the resistor ?
By Zsoltee
#51673
Hello guys,

I have made my first board from the rev2.2 version. It connects to Tunerstudio and i can light up the ignition LED's in hardware test mode ( on the table ), but for some reason injector channels doesnt work.

The ECU runs from USB at the moment through the Arduino. I have saw that i need to power it with 12V and i have tried 12V on 26, 49, 60 and GND to 28. But no luck injector LED's are still blank.

What should i check first? :?

Edit: I think i have found something. Somehow 12V from PIN26 doesnt get to the U1 transistor, because it cannot pass D18 diode. On the connector side of the diode there is 12V, but on the other side is none. The line on the board matches the line on the diode, so its in correct polarity. :cry:

Edit2: SOLVED! 12V to PIN54 and PIN49, its working. :)
By assane
#51955
on jlcpcb.com I don't want to load gerber m52 from github what is wrong? m50 gerber loads without any problems.
By DrRay
#52037
A few posts ago Pazi mentioned the VSS input option.
What code changes are necessary to get this running?
Is there also a VSS Signal if the ASC/ABS Unit throws a code because it didnt get any information from the actual ECU?
By pazi88
#52215
assane wrote:
Wed Jul 21, 2021 4:57 pm
on jlcpcb.com I don't want to load gerber m52 from github what is wrong? m50 gerber loads without any problems.
Don't know. Sometimes gerbers from EasyEda do that. But even thought the preview doesn't work, the PCB's will come out fine. Just add the dimensions (118*155) by hand if it doesn't recognize it.
By pazi88
#52216
DrRay wrote:
Mon Jul 26, 2021 3:47 pm
A few posts ago Pazi mentioned the VSS input option.
What code changes are necessary to get this running?
Is there also a VSS Signal if the ASC/ABS Unit throws a code because it didnt get any information from the actual ECU?
No code changes needed. It should work without any changes (if VSS is wired in the car), although I haven't verified it. VSS input pin is D3 and at least in upcoming FW release, you should be able to use default input pin. The VSS signal should come out of ABS unit also in case of fault.
By pazi88
#52219
Unfortunately I have some bad news regarding these m52 PnP boards. Older rev2.2 to be precise. In some boards there has been mistake where the inj6 trace overlaps with ground plane. This isn't end of the world and you can easily scrape line in the copper to disconnect the trace from the ground. You need to scrape where the blue line is:
Image

Pic above also shows how the faulty board looks like. Here's picture of board that doesn't have the problem:
Image

Here's a picture of that problem fixed:
Image

Also pic from further away to get idea where the problem is:
Image
  • 1
  • 20
  • 21
  • 22
  • 23
  • 24

[/quote] Thank you for this. I copied this spark […]

Random question but I think there are a few bike […]

r8 vag coil weird problem 1uz

Do picture how you do wire

Hardware recommendation

I plan to use the ua4c. I've become more educated […]

Still can't find what you're looking for?