Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
Any strange behaviour, crashing issues etc, post them here! Problems compiling the firmware should go in the General support section rather than here
By Jyri
#51113
I have a Speeduino 0.4.3c and I am trying to control one low impedance injector from inj1 outputs.

Positive going through a relay and fuse to the injector. And negative going from Speeduino through a 5 ohm 25w resistor to the injector.

The problem is that I can use the hardware test page to turn on any of the 4 injector channels, but which ever output the injector is connected to doesn't light up or click the injector.

I have verified the wiring (multiple times) as well as unplugging the connector from Speeduino and directly grounding the injector pin from there that it clicks.

So what could cause Speeduino to not be able to control the injector?

And it is a fuel injected old Lada 2105 with a tbi style throttle body, gm iac, iat, clt and tps. Using 60-2 trigger wheel and vr sensor etc. Everything regarding to the sensors/spark is working, although I don't think that any of this has anything to do with Speeduino not being able to open the injector.
User avatar
By PSIG
#51116
A simple issue like this usually has a simple solution that is (so far) overlooked, such as backwards MOSFETs, board only USB powered, incomplete circuits, incorrect components or placement, solder bridges, wrong board selected, or something else similarly simple.

Post more clues, such as if the INJ LEDs are off with power-up and only light-up when controlled to function (injector connected or not), or verification that the injector or LED is not ON with power-up, voltages and grounds are verified where and when expected, etc. Here's hoping your issue is embarrassingly simple. 8-)
By Jyri
#51121
Thank you so much for your fast reply, the MOSFETs are the right way on the board, I do have 12v on the board and injector and the leds only turn on when commanded to, through hardware test. Except for the channel which has the injector :? It does look like, if I have the injector wired to ch1 the ch2 led blinks one time really quickily on power up, but not ch1(obviously :| )
By Jyri
#51153
I have gone through all the ground on the board and tested the injector+resistor on my bench psu, as well as tried to control a normal relay from the injector output. Nothing works. I also measeured that the 3.3v comes to the mosfet when supposed to, but the led doesn't light (with a load connected), so something tells me that the mosfet is not grounding the pin for some reason. I have as I stated previously tried all the injector outputs and the same thing with all of the four.

I also noticed that my ignition ch 3 and 4 led doesn't illuminate when commanded to, even if there is nothing connected to them.

I also tried to run the board without the vr conditioner or stepper driver, and those had no effect.

If anyone has a deeper knowledge of the board, might know what could cause those problems?
User avatar
By PSIG
#51165
Perhaps you can upload some clear photos of both sides of your board, in-case anyone can spot something.
Jyri wrote:
Fri Jun 18, 2021 12:29 pm
... I also measeured that the 3.3v comes to the mosfet when supposed to
Hmm. A v0.4 board should show regulated voltage signals of around 5V to the INJ FETs. The STP MOSFETS are not actually logic FETs, are intended to be driven with 10V, and may not turn-on under 4V. Especially if they're imported fakes. Despite this, originals seem to do the job at 5V.
By Jyri
#51166
Ahh. I forgot to mention that I am using a teensy, with an adapter board as I had the teensy laying around. I have ordered a mega now, is the 0.4 board not supposed to work with the teensy adapter?

The kit is ordered from DIY EFI, so I think the components are (hopefully) genuine.
By LPG2CV
#51193
by turboedge » Fri Jun 18, 2021 7:06 pm
IIRC the standard FETs on the 0.4.3 have difficulty turning fully on when triggered from the 3.3v output of the teensy.
@turboedge

That's interesting ..... Can you confirm that fets on later boards work?
User avatar
By PSIG
#51210
Teensy adapter boards should have level-shifters that pull the signal voltage up to 5V. Check yours.

for hall the VR1+ should read +5 volts. VR1- is no[…]

Jaguar V12 second edition

I believe more and more on a software issue. Speed[…]

You should be able to use PWM using the VVT tabl[…]

retroject flooding

sounds like you might have some pin misconfigurati[…]

Still can't find what you're looking for?