Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
Any questions you have before you begin buying, building and installing.
#46042
JHolland wrote:
Wed Oct 21, 2020 12:02 pm
In my experience the problem only usually occurs if you have a VR interface set to adaptive mode or if the VR interface is badly matched to the VR sensor. ... With adaptive threshold the increased output amplitude can push the threshold level up to a point where the next tooth is not seen.
+1 to this analysis. "Smart" signal conditioners such as the MAX series in adaptive mode (how most of them are configured) can "blind" the chip to following lower-amplitude signals. As most aftermarket ECMs have used the MAX or similar "smart" chips, this is the default cause for common solutions. The number of missing teeth is not the issue in most cases, nor is the shape of the gap. These are workarounds used to compensate for the actions of certain signal conditioners.

However, this issue can be simply side-stepped by using a different mode, or using a signal conditioner that is not prone to being tricked by these high-amplitude signal spikes. Just use a VR signal conditioner that is not adaptive to variable thresholds. You can read about many projects with these same issues on the forums. Follow their lead.

David

Hi, did you find and solve the IAC issue? I think[…]

Installing a UA4C in my 97 Miata

That would be to tell the stock ECU that an extra […]

Well, two sandwiches, one glass of milk and a modi[…]

does not start

As above. YOU ARE ON DEVELOPMENT FIRMWARE. Pleas[…]

Still can't find what you're looking for?