Firmware live stream happening this weekend: viewtopic.php?f=13&p=43195
Help with building your Speeduino, installing it, getting it to run etc.
User avatar
By george-angelosvoudouris
#41827
Good day to every one

As far as progress none so far the car doesn't like to start even in batch fire mode.
In a conversation we had on the Speeduino Facebook page the signals from the factory distributor will be conditioned better with the Hic-1 board from the factory ECU.
So I started looking for a damaged ECU to get the board so far no lack I will try to update as soon as possible.
Stay safe stay at home.

PS I have attached the pictures for the pinout of the board! (If anyone has any similar ideas and can share that would be awesome
Attachments
91574835_896498927428914_1153021207977656320_n.jpg
91574835_896498927428914_1153021207977656320_n.jpg (33.5 KiB) Viewed 428 times
91378885_896497890762351_2186031185640030208_o.jpg
91378885_896497890762351_2186031185640030208_o.jpg (246.44 KiB) Viewed 428 times
91235145_896941594051314_8471620522306699264_o.jpg
91235145_896941594051314_8471620522306699264_o.jpg (45.22 KiB) Viewed 428 times
User avatar
By gpineau
#41886
Did you ever find an solution to using an external MAP sensor and changing the internal one into a a barometer?
I want to do the same thing but I dont want to hack up the board but I will if I have to.
Would love to have a firmware/tuner studio solution.
By evo_lucian
#41887
george-angelosvoudouris wrote:
Fri Apr 03, 2020 10:13 am
Good day to every one

As far as progress none so far the car doesn't like to start even in batch fire mode.
In a conversation we had on the Speeduino Facebook page the signals from the factory distributor will be conditioned better with the Hic-1 board from the factory ECU.
So I started looking for a damaged ECU to get the board so far no lack I will try to update as soon as possible.
Stay safe stay at home.

PS I have attached the pictures for the pinout of the board! (If anyone has any similar ideas and can share that would be awesome
Since you are using the max9926 based VR conditioner, did you try switching the polarity of the VR conditioner ? TDCM to VR1+ and TDCP to VR1-. Basic distributor trigger settings was buggy when I used it last, a couple months ago. Post a copy of your tune.
User avatar
By george-angelosvoudouris
#41907
@gpineau Currently I haven't done any investigations for the MAP-Baro configuration as I want to tackle the my trigger signal issues first.

@evo_lucian I haven't tried to switch the polarity of the sensors. What I was thinking since the signal that the max9926 output is inverted to switch my triggering from going low to going high. Plus I want to add 2 10K resistors to the VR conditioner to filter the signals

I have attached a pic from comp logger at 140 degrees trigger angle and my tune
Attachments
(58.28 KiB) Downloaded 13 times
trigger pattern at 140 degreed.PNG
trigger pattern at 140 degreed.PNG (48.61 KiB) Viewed 388 times
By evo_lucian
#41976
Going low or going high spark output trigger has nothing to do with the VR conditioner and all to do with your igniter. I will check out the tune in a bit
By evo_lucian
#41978
A few things are off with your tune. Base teeth in trigger settings should be 12 teeth at crank speed not 24 and Trigger edge should be rising not falling.

Turn off wideband o2 corrections

Zero out your cold start ignition advance, it's way too aggressive

Your cranking enrichment is too aggressive.. there is no way you will need 250% enrichment on a factory Honda motor

Your priming pulsewidth is way too high

Your after start enrichment is also too high.

Basically you are over fueling the motor, adding way too much ignition and your trigger settings are wrong.

Also don't forget to unlock your fixed timing after setting trigger angle.
By evo_lucian
#41994
Walterronny wrote:
Fri Apr 10, 2020 11:21 pm
evo_lucian, what should be the best and more stable basemap for start it up and honda engine? Thanks!
The generic speeduino base map can work with some tweaks.

For customers' cars I usually use my own basemaps
User avatar
By george-angelosvoudouris
#42007
@evo_lucian oh I forgot about the trigger teeth 24 if the sensor is on crank 12 if on cam correct? Thanks for the tips I'll check them one by one!

I decided to check the distributor signals on the bench for the factory distributor! So speedy on the bench a second distributor I had laying around hand drill and off we go!

I noticed 2 things.... on low RPM (cranking) I get to many trigger signals on higher RPM the signal starts to clear up!
The second thing is that as I stopped the drill and came at a full stop I saw all the ignition LEDs come on and then they stoped!

i have attached a composite logger file if someone likes to take a look
Attachments
(25.86 KiB) Downloaded 11 times
PCB for BMW m52 engine

Hi Pazi. Please tell me how to use VW red ignitio[…]

NA VVT Swap No Start

Relevant manual page: https://wiki.speeduino.com[…]

E190 2.3 8V FUEL ONLY

I think there is a reason why OEM bosch costs 70$ […]

May 2020 firmware release

I could try the 680 ohm, but the onboard pullup […]

Still can't find what you're looking for?