Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
For anything you'd like to see added to Speeduino
By choyr
#22935
Only now i have access to the engine. I installed the distributor and cranked it but no signals detected. However, when i remove the distributor and spin it quick enough with my hand, it detects the rpm. This is also the issue i found when i was bench testing it. Anything i can check? I already played with the settings in TS
By M.Itani
#23023
hey guys! i would also like a decoder for toyota 7mgte ! i got my car running but it has also of misses and RPM gauge jumps all around ! its a 24 tooth and 1 tooth but 2 sensors on the 1 tooth 180deg appart

the setting i have it 12-1
NE to vr1+
G1 and G2 to vr2+
the 3 grounds to vr1- and vr2-

im also running the stock ignitor with a small board to work around the multiplex

i have an extra CPS i can put on the vice and spin with a drill but no logger unfortunately

if you guys need any help or testing let me know
By stum
#23033
Hi M.Itani,

I think your problem is that you have both G1 & G2 connected up. you should only need one of these, as they are the Cam sensor trigure, and you have one firing every engine rev, not every secone as a cam should.

On My Toyota 3vz-fe I and using G2, only and it is sweet. there was a reason why, but cannot remember why now. its on here some where, was a setting someone else used/recomended. Im also using the standard Dizzy, and Ign module. runs sweet and easly spins to 7000rpm, and smokes the tires :)

If you give that a go, you should find an approvment.
By M.Itani
#23043
this problem is killing my head lol!!

the cps spins half a turn for 1 engine revolution so 12 teeth
if you use only 1 cam sensor it means the ecu only get one signal every 2 engine revolutions.

so if i still wanna use both g1 and g2 i would have to make the setup in TS 12+2 ?? or does this change something ?

its very hard for me to wrap my head around that kinda of thinking because im not to knowledgeable in ignition timing or injector timing
User avatar
By PSIG
#23045
M.Itani wrote:
Thu Dec 14, 2017 11:07 pm
the cps spins half a turn for 1 engine revolution so 12 teeth
if you use only 1 cam sensor it means the ecu only get one signal every 2 engine revolutions.
Correct. Disconnecting G1 and grounding that output pin will make the distributor output a 12/1 signal (12 per crank rev, and 1 per cycle). Not 12-1 (12 per rev and 1 missing per rev). ;) Your settings would be Dual Wheel, Primary Base Teeth 12, Secondary Teeth 1. This would allow it to know cycle (cam) info, permitting sequential injection.
M.Itani wrote:
Thu Dec 14, 2017 11:07 pm
so if i still wanna use both g1 and g2 i would have to make the setup in TS 12+2 ?? or does this change something ?
Correct, but it would technically be a 12/2. "+" or "-" indicate added or subtracted teeth on the same wheel, while "/" separates crank and cam signals (360°/720°) This will not allow sequential, as it sees a "cam" signal every crankshaft revolution. Speeduino may be confused as the two "cam" signals are so far apart, as it is expecting to see both /2 'cam' signals on the same crank 12/ revolution. So, 12/1 setting may actually work if using both G1 and G2 sensors. I have not tried that, so I can't say if it will work for sure.

I would suggest trying the method posted earlier — disconnecting and grounding the distributor module output for G1. This could be as easy as moving the G1 wire from VR2+ over to VR2- for testing. Make a trigger log (if you have registered TS) or an oscilloscope image of the signals to post here if possible.

David
By M.Itani
#23046
i did get TS registered but i dont really understand the ignition logger it shows a graph with lots of bars that i cant make sense of!

as for grounding G1, how would i go about doing that ? till now i just left it disconnected when not used ...
User avatar
By ktop
#23058
Hello Itani,

the bars are signal, can you post a screenshot at least of that ?

By grounding G1, the guys mean to connect it to the ground (GND) or VR2- as stated above.
Leaving it disconnected it may not be a good idea as pointed out previously by PSIG.

Both G1 and G2 are located across each other in the dizzy, so I don't think (in my head) that one would be different than the other, but there might be difference.
  • 1
  • 4
  • 5
  • 6
  • 7
  • 8
  • 14
540HP NA 7L V12 3Seater

Thanks for the suggestion, I had not considered th[…]

Decoders - What do you want to see?

Please at least download TS and load the base tune[…]

Ford TFI

OK, thanks for that. So, the system is Ford DIS, […]

I was wondering if it would be possible to set the[…]

Still can't find what you're looking for?