Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
For any discussion not specifically related to your project
By GabeZ
#51135
Hi everyone,

Have had speeduino running my project for about 1000 miles or more, working well until now.

Latest firmware, using 24/1 optical sensor at cam speed, dual wheel code, distributor with single ignition output
OEM Nissan ignitor, 12v
v0.3.6 board

Truck was running well, shut it down and tried to restart 2hr later, had a hiccup during cranking and no start.

No spark, hot ignitor, ign1 channel led stays lit. I am getting cranking rpm and speeduino code does not seem to be corrupted or changed from last configuration.

Should I be looking into a hardware issue on the board or arduino?

Tried 2 different coil/ignitors, same problem, ign1 led stays on solid with ignitor connected or not.

I have access to another arduino mega, perhaps failed output on that?

Just looking for tips as to where to start to save myself some time, appreciate any info!
By GabeZ
#51137
Ok, some progress, I seem to have fried one of my tc4424. Switched the 4424 and problem moved from ign1 to ign3, and the TC4424 was getting hot.

So I removed the failed TC4424, using the good one on ign1 truck is running again.

What should I look into as far as preventing this problem in the future? I am glad I installed sockets for these, and will buy some more to pack as extra, but would like to try to prevent this.

Too much current?

I am using a little bit more dwell than most installations at 3.5ms. I scoped a running Nissan using this same ignitor and coil and was surprised to see it was running 4-5ms dwell in the factory configuration, with a 10.5v peak.

Too much dwell?

Or could it be my cranking dwell? I never did adjust this I believe it is at 4.5ms.

I had not checked heat of the tc4424 before this problem. I am willing to switch to a different ignitor/coil if necessary.
#51140
I scoped the ignition output of a 90's Nissan 4cyl ecu (uses same PRW-2 ignitor and coil) using a digital bench simulator at rpm of 2000-5000 rpm.

I found 5ms dwell tapering to 4ms dwell at higher rpm, 10.5 vpp.

Not thinking I needed that much dwell, 3.5ms seemed to work fine, coil and ignitor were cool and no misfire until now.

Running again now with the other TC4424, after about 10 minutes nothing seems hot, same settings as before.
#51142
Also the PRW 2 and coil seemed to have survived this. They may have been on multiple times while I was diagnosing with key left on. The ignitor was too hot to touch, but runs cool with the other TC4424 so far.
#51185
Looking at original pulse to PRW2 ignitor, ignitor goes on (input high 10.5v) and coil starts charging, ignitor turns off (input low) and coil fires.

I have speeduino set to Spark Outputs Triggers = Going Low

I have the ignition output jumpered to 12v on speeduino

I never have scoped the speeduino output to the ignitor. I am guessing the way I have it set to have a similar pulse to the original output, but probably a near 12v peak voltage and slightly shorter dwell. I analyzed the original ecu and system before installing speeduino, so I did not have a lot of trial and error, it just seemed to follow my calculations.

I probably have much more than 1000 miles on it, and lots of run time in the driveway. Everything seemed to be running cool and correctly as far as the ignitor/coil were concerned, I did check temps.

Curious about the long dwell time of the Nissan original system, I did reduce dwell until I was getting misfires. These times were under 3ms but I forget exactly. I know around 3ms dwell is recommended for most and this seemed to work ok. I compromised at 3.5ms running dwell, as I didnt want any possible misfires during initial tuning.

I have built and tuned many other efi systems in the past, and had access to all the data I needed before I set this up, so I dont believe that I prematurely abused this 4424.

I am very surprised I didnt melt any traces on the board, smoke the 4424 completely or the ignitor, or coil. Like I said when this didnt start (the only time I have had a failed start on the speeduino btw), I had the key on for 15minutes or more at a time trying to find the problem.

Once I found ignitor was too hot too touch, I quickly disconnected it. I then checked speeduino and found the LED lit, and the 4424 too hot to touch.

Is there very little failure rate of the 4424 under normal conditions? Maybe I got a bad chip

Does too little of dwell for the ignitor and coil cause excessive current or problems in any way? I wouldnt think so but am looking for ideas

Perhaps I had a weird startup glitch, where speeduino reset or my crank triggers were in an odd or reverberating condition? I would think overdwell protection would protect this but maybe something strange happened.

I am going to buy some more 4424 as backup, and familiarize myself with re-configuring the ignition output pin in the code in the meantime if I fry my last one. I should be able to look at datasheet and cut a bad leg off a half-dead 4424 correct?

I appreciate the help, thanks!

logs are going to be needed. Zip them :) the inje[…]

12V hall sensor

http://i.imgur.com/CdNYxlU.gif?1 Note in that W[…]

no spark

at tdc my crank sensor is in the centre of the mis[…]

PCB for BMW m52 engine

A few posts ago Pazi mentioned the VSS input optio[…]

Still can't find what you're looking for?