Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
Help with building your Speeduino, installing it, getting it to run etc.
#51913
When I crank my engine I see that there is no readout on the tuner studio engine speed tachometer.

Here is my build;
4age (4 cylinder) 16v + 20v ITB conversion
hall effect sensor + 36-1 trigger wheel
COP conversion
narrowband o2 sensor - oem toyota/bosch sensor
speeduino v0.4c with mpmx4250 sensor

My other sensors have all been calibrated so with this I am lost. I used an oscilloscope to see if I am even getting a square wave signal and I am as shown below. In addition I've added some other pictures that may be relevant as well as the msq file.

Any help would be appreciated. Thank you for your time.
Attachments
(77.49 KiB) Downloaded 30 times
627e956e31144d6f3f0ea222e5f3b4d1.png
627e956e31144d6f3f0ea222e5f3b4d1.png (71.7 KiB) Viewed 654 times
e9cb2a355fb6715690f5dac080050978.png
e9cb2a355fb6715690f5dac080050978.png (43.91 KiB) Viewed 654 times
b8d1aa900751131df0fab23c6b668691.png
b8d1aa900751131df0fab23c6b668691.png (44.86 KiB) Viewed 654 times
882d88e604f8232f6d336125331b3955.png
882d88e604f8232f6d336125331b3955.png (34.22 KiB) Viewed 654 times
#51914
GunnersonD wrote:
Mon Jul 19, 2021 11:51 pm
… I used an oscilloscope to see if I am even getting a square wave signal and I am as shown below.
Bummer. You are confirming a crank signal where? Hopefully at the processor pin. If found there, it's a settings or setup issue. If it's not there, then keep working outward until you find it. Fix where it stops.

Post a short log of cranking with the issue. Take a deep breath, as it's usually something simple. Can we assume jumper JP2 is correctly positioned?
#51917
PSIG wrote:
Tue Jul 20, 2021 12:24 am
GunnersonD wrote:
Mon Jul 19, 2021 11:51 pm
… I used an oscilloscope to see if I am even getting a square wave signal and I am as shown below.
Bummer. You are confirming a crank signal where? Hopefully at the processor pin. If found there, it's a settings or setup issue. If it's not there, then keep working outward until you find it. Fix where it stops.

Post a short log of cranking with the issue. Take a deep breath, as it's usually something simple. Can we assume jumper JP2 is correctly positioned?
I took the signal directly to the connection on the circuit board. I had bought one of the prebuilt boards and failed to add the jumpers . That's on me so thank you for that. But as for JP2, the board I have has the jumper labeled as DIRECT/TSC and a quick reference to the v0.4 page , https://wiki.speeduino.com/en/boards/V04, tells me that I should configure it such that it bypasses, or at least doesn't use, the VR conditioner. I am hesitant to jump either but I know I need to jump one. I'm leaning towards the DIRECT side but I don't know what either stands for. I can't seem to find documentation to specify which is which. I'll try again tomorrow, I don't want to wake sleeping neighbors.

-I wasn't expecting such a quick response thank you.
#51990
theonewithin wrote:
Tue Jul 20, 2021 7:02 am
Direct is what you want on a 5V square wave hall sensor.

TSC goes through the signal conditioner.
Upon installing the jumpers correctly and with the help of some starting fluid I was able to get it to run. Now for timing. I'm replying to say thank you and I really appreciate your help. Spent the better part of 4 years in the garage and now can move under its own power. Thanks again.

just a heads up that some times diagrams are shown[…]

r8 vag coil weird problem 1uz

Do picture how you do wire

Hardware recommendation

I plan to use the ua4c. I've become more educated […]

the Serial output is in Lambda on these controller[…]

Still can't find what you're looking for?