Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
Help with building your Speeduino, installing it, getting it to run etc.
By stum
#48475
Hi all,

Over the last 3 years I have battled on and off with the Toyota Stepper IAC........ Always coming out second best. So out it went and in went a generic 2 wire IAC valve.

Like any good race car/truck owner I left it until the day before the next event to connect it up. How hard could it be.........

Shell we say the 1/4" BSP ball valve is doing a great job for now :shock: And is out competing today

I have 12V on one terminal.
I have the other terminal connected back to the IDC pin 37
Checked with My multi-meter

Set to PWM open loop 2 wire, 120Hz.....

Played with all the Cranking and running settings.... and cannot get more than 200mV (sh) across the pins, possibly just noise.. While cranking (in flood clear mode so it will not start) set at 0%....50%....100%....... no difference

Almost like the pin has been assigned another task and set to off.

Firmware 2019/03 - I know not the latest version but my old laptop is all but dead, one usb still working, no WiFi....... I am getting another one ready.... but not quite ready yet.
Pre assembled V0.4.X board from Josh in Australia.

I still have the stepper driver plugged in. Is this likely to cause a problem.

Is there an easy way to test, or find out what the pin assignments are (in case it is doubled up). My next place to look will be checking the Mega pins and voltages on the speeduino board. after the weekend when the truck is back.

Thanks in advance. StuM
By stum
#48478
Wish I could....... As I mentioned the old laptop.......
Will talk to speeduino (most of the time). but will not load the drivers for a usb etc.

I was hoping for an easy answer....... Dreaming mate.

I have check all the other mappings for other outputs ie NOS, Fuel pump, Fan....... and none are using "Pin 5" ie default IAC.

From init.ino for V0.4 board "pinIdle1 = 5; //Single wire idle control"

Thanks for the offer of help LPG2CV.

Starting to sound like I might have to pull my finger and finish off the new laptop
By LPG2CV
#48479
pinIdle1 = 5; //Single wire idle control
pinIdle2 = 6; //2 wire idle control

I just pull out the choke to lift rpm :D

there are other settings in other idle areas to consider. have you tried those?
By stum
#48481
Depends on the technical......

One wire is actualy a two. ie +12 and earthed via speedie
two is a 3, ie pull open and closed + 12v.

Well that is my understanding.

Yes I played with all sorts of settings, clicked on most. Open, closed, 1 wire, two........ spent about 2 hours feeling the love :roll:

Unless you have some magical thoughts???
By LPG2CV
#48483
Not my area, but I think work has been done over the last few years to improve idle control in its various flavours.

An upgrade is imminent , and if I recall, there is a small bug fix for stepper.

So a working laptop is probably the way forward. :) But obviously, not until the night before the race. :lol:
By stum
#48545
I do not think that is the problem, normal a fly back diode is only needed when it works :shock:

I can not get the speeduino output to ground the -ve side of the IAC valve.

But thanks for the ideas...

Cheers StuM
EMI while cranking

Yeah, it doesn't totally rid the problem...dependi[…]

… do I understand it correctly that the in[…]

Наш центр специализируется на современных методах […]

Наш центр специализируется на современных методах […]

Still can't find what you're looking for?