Any questions you have before you begin buying, building and installing.
#60815
Izzy46 wrote: Tue Jan 24, 2023 12:17 pm I've checked the output of Ignition 1 (pin7) and it's 0.15v when cracking. I seem to remember that previously it was 1.1v when cranking but am not 100% sure....
Your reading is an average, of mostly 0V an an occasional 5V dwell pulse. The concern is if it is substantially different than before. Compare tune settings and check wiring connections if a problem exists.
Izzy46 wrote: Tue Jan 24, 2023 12:17 pmI'm hoping that my tune settings are correct and that the attached tune will produce a spark from a GM 8 pin module? I'm wondering if someone could kindly take a quick look to see if the basics are in place?
Offhand, looks OK, if everything is connected for how the tune is set. Are you following the GM7/8-pin setup outline in the Wiki? If the module B pin (Bypass) is grounded, the distributor should fire without signal from Speeduino (self-fire).
Izzy46 wrote: Tue Jan 24, 2023 12:17 pmI'm also a little puzzled as to why "Trigger Pattern" is set to "Basic Distributor" rather than "GM7X" given that I'm using a GM 8 pin ignition module?
The GM 7x is a special crank/cam signal decoder for certain GM engines with multiple waste-spark coils. It is not related to the GM 7-pin or 8-pin modules. The GM HEI distributor outputs a basic distributor signal, so that's the decoder used.
#60914
Over the last few days I’ve been working to get the boat started without much luck.

Before the winter break I had the boat running using Dupont connectors, alligator clips and Apollard’s base tune. In hindsight, this was a miracle as the tune was for a v0.3 with throttle body injectors, whereas my setup is v0.4 with port injectors. The boat started consistently but ran very rich and a little rough. The throttle cable was disconnected and I never revved the boat.

Since that time I’ve soldered the relevant outputs to a plug and have everything connected up in a waterproof box. I’ve only connected the injector channels 1 and 2 and the ignition. I plan to connect the water temp, oil pressure, MAP and TPS once the engine is starting consistently.

At the moment I note the following:

- There is consistent and strong spark,
- There is pressure at the fuel rail and the injectors click when I turn the engine over.
- The LEDs for injector channels 1, 2, 3 and 4 light up when the engine is turned over and TunerStudio reads 150 rpm
- The distributor is in the same position as when the boat was running so I’m confident the timing is correct. The B terminal on the ignition module is grounded and the timing is being set by the GM 8 pin ignition control module.

I’m trying to understand why the engine is not firing and my best guess is it’s something to do with the injector setup….

I have eight injectors which are wired into a 4 pin plug. Two of the pins are connected to a red wire and supply 12v to the injectors. There is one pin connected to a blue wire that supplies a ground to 4 injectors and a pin connected to a green wire that supplies a ground to the other 4 injectors.

When I look at the ‘Injector Layout’ on TunerStudio there doesn’t seem to be an option that matches my setup exactly.



Paired: 2 injectors are wired to each channel. The number of channels used is therefore equal to half the number of cylinders. (I have 4 injectors wired to each channel)

Semi-Sequential: Semi-sequential: Same as paired except that injector channels are mirrored (1&4, 2&3) meaning the number of outputs used are equal to the number of cylinders. Only valid for 4 cylinders or less. (I have 8 cylinders)

Sequential: 1 injector per output and outputs used equals the number of cylinders. Injection is timed over full cycle. Only available for engines with 4 or fewer cylinders. (Definitely not this one)

I’m wondering which setting I should use and whether this is the reason the engine is not firing? Could it have something to do with the Trigger Angle (Deg)....?

This is the first time I’ve actually considered how injector and ignition timing work together to create a balanced and running engine. At this point I feel like I’m stumbling around in the darkness, trying different things hoping the answer will hit me in the face!

Once again any ideas are greatly appreciated.
Attachments
(82.63 KiB) Downloaded 50 times
Screen Shot 2023-01-30 at 9.11.39 AM.png
Screen Shot 2023-01-30 at 9.11.39 AM.png (306.32 KiB) Viewed 1584 times
#61630
Just read your thread. Good to see another boat conversion. I don't get a lot of opportunities to check here often but will check back more frequently to see if I can help.

A couple of comments:

The O2 spacer works fine, no over heating. I used two for a couple of years until I switched to stainless tube risers and had ports welded in. I suggest keeping the spacers and not welding them in, mine cracked around the weld and the engine ate enough saltwater to require a re-ring and new valves. I'm going back to the spacers soon (I keep the O2 just for reference and to make me feel better).

I would not try to tune a boat engine without a wideband. Car engines are more tolerant of lean conditions so tuning by feel and plug reading works well. Boat engines are attached to a water brake dyno 100% of the time, lean burns things up fast.

As pointed out earlier, use marine components or mount them away from the engine (separated by a compartment).

I've had no issues at all with the connector and case I used, nor the GM weatherpack connectors. I boat in salt 90% of the time.

I would change the injector wiring to match the wiki and used paired injector settings. However, that should not keep you from starting the engine (as you found out before). Since you had it running before and it doesn't after soldering the wires to the board, I suspect an error in that process. Re-check every wire to be sure.
#61631
Also, I think you need to change the stoichiometric ratio to 14.7 in the dialog above. This tells the firmware you are using gasoline, it's not the AFR target you desire. The AFR targets are in the tables, not here.

PSIG, please correct me if this is wrong.
#61683
Thanks apollard for the advice,

I've followed your posts closely and tried to model my build after yours.

Over the last few weeks I've had a number of setbacks as a result of inexperience and poor soldering techniques. I was able to get the boat started and sounding really nice with a few quick revs in the driveway. Strangely, the engine only seemed to rev up once the fuel pump was disconnected and fuel pressure was close to zero.....

I've got my engine constants setup as follows:
Screen Shot 2023-03-06 at 8.55.11 AM.png
Screen Shot 2023-03-06 at 8.55.11 AM.png (451.71 KiB) Viewed 1152 times
I've entered the injector flows based on the follow website which states: "Flow: OE Specifications - 24Lbs/Hr Flow at 43.5 PSI Fuel Pressure (27Lbs/Hr Flow at 58 PSI Fuel Pressure )"

https://www.ausinjector.com/mar102-8n/

I'm not really sure why the engine only responds with low fuel pressure.

The other strange occurrence I keep experiencing is the clicking of fuel injectors once I'm done cranking the engine. At this point I've soldered two boards with both boards experiencing the injector clicking. As I've built my engine harness and injector harness from scratch it might be a good idea to map out the harness to be sure I haven't made any obvious mistakes.

I'm onto my third board at the moment, so I'm hoping it's a charm! I guess this means I have to complete another two Speeduino projects with the spare components I have :D My wife just loves how half of the dining table has become a permanent electrical workshop :lol: :lol: :lol:
#61699
When it won't rev, are there signs of running rich (smell, smoke, etc)? Being wet exhaust will cover up some of these, but should still be some signs if it's running rich. Also, I would get the info directly from the injectors and look that up. Indmar may have used something different than Mercruiser.

Check calibration on all sensors (temps and MAP), that can cause some real strange issues. I forgot to re-calibrate once when I changed MEGAs, and it caused bad running. Sensor calibration is written to the controller, but with a new controller just loading the tune doesn't calibrate the sensors.

I can't comment on the MAP switch setting since i don't use it. But otherwise, nothing I see in those dialogs that should cause issues.

When it revs with the fuel pump unplugged, I assume it only runs a short while and then runs out of fuel?
#61794
I finished soldering my third Speedy board but have still managed to make a mistake somewhere…. Essentially the process went perfectly, beautiful silver solder joints shaped like Hershi’s Kisses everywhere. There was nothing I could identify as a problem, however when I connected Speedy to the Mega board it would turn the Mega off. After cleaning the soldering paste from the board with some contact cleaner it seemed to function well.

I then took the board out to the boat and plugged it back into the main harness. I then tried cranking the engine a couple of times without any luck. I then noticed that Q4 mosfet (injector 3) was very hot to touch. The mosfet would heat up as soon as the board was connected and turned on. I tried all kinds of harness and injector combinations but it always came back to Q4 mosfet. I even plugged in my original board to see if any of the mosfets would heat up but they didn’t.

I took the board back into the house and did some testing of the injector circuit components to see if I could discover anything.
Screen Shot 2023-03-12 at 9.47.40 AM.png
Screen Shot 2023-03-12 at 9.47.40 AM.png (140.56 KiB) Viewed 973 times
Everything on the injector circuits seems normal except for the resistance of R1, R2, R16, R17.

R1 = 85k
R2 = 86k
R15 = 78k
R16 = 35k

This is different to my first board where all the resistors test at 99.9k.

I also removed the injector 3 mosfet from the board and it tested normally although it was very slightly delaminated from the heat.

At this point I’m trying to find a way forward. I’m on to my third board right now and want to understand what might have happened to this board before moving forward. At this point I have two theories.

I didn’t clean the excess solder paste and this caused a short somewhere.

A couple of years ago I replaced 4 injectors on the boat. The new injectors were compatible and functioned fine except that they didn’t have mounting clips for the injector harness. This meant that I had to lock the harness on with cable ties. After creating a new harness I did not attach the harness to the injectors with cable ties. Is it possible that an injector got disconnected causing the resistance of the two parallel injectors to move from 7.25 ohms (2 in parallel) to 14.5 ohms (for a single injector) Could this have caused the damage….?

I’m wondering if I can replace the resistor R1, R2, R15, R16 and make sure the injectors are well connected and then get back to it?

Any advice would be much appreciated as always.
#61801
Testing parts while installed in a circuit (even w/o power) will effect the values read due to the influence of other components (in this case, the MEGA, mosfet, and other resistors). However, similar components should read very close to each other. For example, R1, R2, R15, and R16 should read close to each other. R16 being lower than the group indicates a possible problem.

It's also possible that the MEGA pins didn't power down in the same state (not likely, but since it can be removed I would before checking parts.

Having different injector loads should not cause a problem with the electronics, unless the load is so low it damages the mosfet. Two injectors on each mosfet works fine.

So;
Remove MEGA
Check resistors in the mosfet circuits
For any that read different from the same group, desolder one lead and check

Report back what you find. We need to solve this problem, then we can diagnose why you aren't getting action during cranking.
  • 1
  • 2
  • 3
  • 4
  • 5
  • 20
Can bus problem with STM32

I placed a 120 ohm resistor on the speeduino side […]

How bad did I mess up my PCB

It's probably recoverable. Take a look at the sche[…]

Suzuki RE-5 EFI Conversion

check the relay is clicking, and the fuse. Check t[…]

That’s awesome! Congrats! So you were still[…]

Still can't find what you're looking for?