Anything not specifically related to the Speeduino hardware. Eg sensors, bluetooth, displays etc
By noisymime
#5279
Support for all 3 wires on these valves has been added and bench tested as working well. It is definitely better than with the resistor, really quite smooth, and from what I can see has a usable range from about 10% to 90% duty cycle, which is very good (I've seen other setups where it can be limited to 30%-75%).

On the v0.3 board, the default outputs are on Q6 and Q8, aka S2 and S4 on the screw terminals
On the v0.4 board, the default outputs are on Idle and Boost.

I have a few questions for anyone who has used these valves with other ECUs...
  • Is a smooth humming / buzzing when operating normal for them? I find the valve is smoothest when running around 160Hz with a reasonable even hum. At 120Hz its still smooth, but more of a buzz, lower in pitch. At something like 60Hz its just terrible
  • What is the expected behaviour off idle? Should they be fully open or fully closed or just remaining at their last set value?
Happy to assist if anyone out there wants to test
By androidcho
#5286
For the humming, I can say - yes, it's normal and on BMW M50 it can be heared when you turn the key, it starts buzzing. One diffrence between Speeduino and the Bosch Motronic is that the Motronic sets the position of the valve when the key is turned to contact, not when some cranking rpm's are seen.
My 50 cents..
By edc_atl
#5294
noisymime wrote:Support for all 3 wires on these valves has been added ......
I have a few questions for anyone who has used these valves with other ECUs...
  • Is a smooth humming / buzzing when operating normal for them? I find the valve is smoothest when running around 160Hz with a reasonable even hum. At 120Hz its still smooth, but more of a buzz, lower in pitch. At something like 60Hz its just terrible
  • What is the expected behaviour off idle? Should they be fully open or fully closed or just remaining at their last set value?
Happy to assist if anyone out there wants to test
They do buzz alot when in operation but hardly noticeable when the exhaust has not been installed. :lol:
User avatar
By PSIG
#5298
+1 they are noisy. Most factory app's I'm aware of are about 100Hz. I would assume default is system-dependent with behavior off-idle based on the dashpot (idle recovery) scheme.
Image
David
Tach output and RPM sensor issues

By somewhat better I meant that before adding the […]

I saw this suggested on GitHub. I've used programm[…]

BMW E23 M30B28

Ignore my previous posts, I'm an idiot. Turns out […]

He's quite prolific with respect to video and elec[…]

Still can't find what you're looking for?