Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
For discussion of Speeduino compatible boards designed / built by other members of the forum and for guidance around making such a board
By Jansun
#17357
Is there anyone who can tell me in simple steps what the error codes does?

I dont have to know what the solution is for my problem, i just want to know what it does and how it works.. Just to know the basics.
User avatar
By PSIG
#17359
I would just try to change the traces to other inputs (IAT, O2, etc.) to see if they work on the same log. If so, be sure to try any you may use later to verify function. I'm thinking it's a simple error in the "name" of the field or data name. Change them to check.

David
By Jansun
#17361
Thanks for the help, but this is not what I want to know right now. Is there somewhere documentation about error codes in general?

- from speeduino comunity
- from tunerstudio manuals
- from megasquirt manuals
- ANYTHING where i can understand the FUNCTION
User avatar
By PSIG
#17364
Sorry - I did a quick look for Error info with no luck. I was just trying to see if there was a simple solution to the problem so it didn't need research. My MLV works with your log and no errors.

David
By apollard
#17366
Tried it on my machine, but didn't get the Error # you are seeing. Same MLV version, 4.1.14 . Not sure if you are registered (or if it would make a difference). Maybe try the old standby re-install?
By apollard
#17396
Not that I have found. EFI Analytics makes great software, butmdocumentation isn't great. Sometimes docs just don't exist.
By Jansun
#18045
Small update. Haven't been working on the injection lately, had some other projects that had priority.. About the project, I have a lot of troubles and with the missing electrical experience it makes it sometimes a hard one, but that's also why i'm here, to learn. And to write down what i have leared during the project :D To make it even harder i used a car without a running EFI, so all problems that pops up could be one of the ecu, but also in the wiring, sensors, fuses, relays, etc. So lets be sure all exept the ecu itself is working.

I refurbished an old MS2 and soldered an adapter for the ecu connector to connect the ms2 directly to the existing wiring. I also modificated the ms2 a bit, i removed the rs232 ic for a FTDI communication.

There was a strange issue with the ftdi tool and the ms2, when i disconnect the tool, the coil output wont fire anymore. with the tool connected also not, with the usb cable it did. Also the car wont start, no matter what. Because i can switch between old and the ecu with one wire i noticed the ecu runs perfect when im not cranking (switching wires on idle with the old ignition to the ecu). Turns out i got an old model ms2 thats goes to boot mode when Rx is held low. So modified the ftdi board and now the coil if firing properly on all conditions.

The strange issue is, the cranking issue is also solved.. Starts immediately! Huh? So ther Ftdi tool had a sideaffect on the cranking conditions? Doesn't make sense, does it? I noticed the same issue ony my own ecu, but i dont see how this could be the same issue..

SO.. Lets see last as a small succes (i got an ms2 to work, Yey!.. lol) and lets go on with it! For now first i need to get the fuel injector to work, so i cant switch from LPG to petrol and finish the car and wiring itself to a propper working environment.
By Jansun
#18796
OK, back again. Got a question. First picture:
20170524_212017.jpg
20170524_212017.jpg (3.09 MiB) Viewed 2124 times
Everybody knows what this is right? :D Runs great! No problems at all with this unit. Then, second picture:
20170524_211238.jpg
20170524_211238.jpg (3.5 MiB) Viewed 2124 times


Won't start. Got an RPM, but wont start. Sometimes, when i stop cranking the car, the engine starts to run!

Anyone a clue?
Attachments
(24.71 KiB) Downloaded 71 times
  • 1
  • 12
  • 13
  • 14
  • 15
  • 16
  • 17

Coffee break: The Tuner Studio gauge shows Speedui[…]

Minimalistic ECU (RC engines)

Another pic with components. There is nothing on[…]

does not start

Here's the startup log, but it never started. I ha[…]

Thanks for answers, have a good day. I have seen […]

Still can't find what you're looking for?