Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
For discussion of Speeduino compatible boards designed / built by other members of the forum and for guidance around making such a board
By marogarage
#52054
Hi, i have speeduino for m50nv 2.0rev without vr conditioner, im using m52 hall crank sensor. My problem is that ecu can't see any rpm. I find out that VR1+ and VR1- are connected with 1Kohm resistance and VR1- so i have +5v at both pins(VR1+ should be +5v output power supply for sensor and VR1- should be signal input high and low condition, am i right?). Have you guys any ideas what may be wrong?
User avatar
By jonbill
#52057
vr1+ is the signal from the hall sensor and vr1- isn't used with hall sensor.
the sensor also needs +5v from speeduino and a ground at the speeduino.
you should get a 5v square wave on vr1+ when the engine is turning.
I'm pretty sure this is in the wiki.
By marogarage
#52061
jonbill wrote:
Tue Jul 27, 2021 7:51 am
vr1+ is the signal from the hall sensor and vr1- isn't used with hall sensor.
the sensor also needs +5v from speeduino and a ground at the speeduino.
you should get a 5v square wave on vr1+ when the engine is turning.
I'm pretty sure this is in the wiki.
Thanks a lot! So basically i need to make sensor signal into VR1+, sensor supply from +5v and sensor ground into ecu? it sounds good but why do i have +5v at vr1+? is this correct?
User avatar
By jonbill
#52063
Yes, that sounds right.
I don't know whether you should or shouldn't be able to read +5v on VR1+ - do you have the jumpers on the board correct for hall?
on the 0.4.3 boards there are jumpers to select direct or signal conditioner (hall/ vr) and whether to enable a pullup for the hall. (which suggests maybe it should be pulled up to 5v, but I don't understand electronics well enough to be sure!)
By marogarage
#52065
jonbill wrote:
Tue Jul 27, 2021 9:50 am
Yes, that sounds right.
I don't know whether you should or shouldn't be able to read +5v on VR1+ - do you have the jumpers on the board correct for hall?
on the 0.4.3 boards there are jumpers to select direct or signal conditioner (hall/ vr) and whether to enable a pullup for the hall. (which suggests maybe it should be pulled up to 5v, but I don't understand electronics well enough to be sure!)
jumpers configiratuion is correct with official pazi schematics, but it makes the +5v at VR1+, im confused idk is this correct
By marogarage
#52067
theonewithin wrote:
Tue Jul 27, 2021 10:16 am
That's correct.

The jumper pulls the input up to 5v.

Your sensor pulls it to ground when a tooth passes.
Thanks mate! So i will make VR1+ as signal, some +5v to supply sensor and sensor ground to ecu and it should work. I will let you know if it worked. Thanks a lot guys!

[/quote] Thank you for this. I copied this spark […]

Random question but I think there are a few bike […]

r8 vag coil weird problem 1uz

Do picture how you do wire

Hardware recommendation

I plan to use the ua4c. I've become more educated […]

Still can't find what you're looking for?