Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
For any add-on boards such as VR conditioners, optos and OEM interface boards
By c42
#42574
Unfortunately I had tried downgrading to build 2.2 but Ardustim has a line of code requiring a minimum build of 3.**
I have tried altering the line of code to say 2.2 but there are further errors cropping up later. I probably need to find an older version of Ardustim to load.
Any other ideas welcome.
Cheers
John
By notarobot
#42575
@c42 I have exactly the same problem using SerialUI 3.2.2 .

I would try 2.2.2 if I could find where to download it but sounds like that does not work either. Hopefully someone can chime in with which are the latest versions of ardu-stim & serialui which work together and where they can be downloaded from.

John
By notarobot
#42578
After some testing here I found the following combinations of Ardu-stim & SeriaUI compiled without errors:-

Ardu-stim 6 Jan 17 + SerialUI 1.4
" 3 Dec 17 + " 2.1.6
" 22 Feb 18 + " 2.1.6
" " + " 2.2.2

Ardu-stim files were downloaded from
gitlab.com/libreems-suite/ardu-stim

SerialUI files for 1.4 & 2.1.6 were downloaded from github.com/psychogenic/SerialUI and installed in Arduino IDE via install zip library.
SerailUI 2.2.2 was installed via Arduino IDE libary managemnt (select version to install in drop down list)

I have not tested program operation at all yet - this was just to get rid of compile errors.
John
  • 1
  • 4
  • 5
  • 6
  • 7
  • 8

Is there a reason why you want to log this info? […]

MX-5 (Miata) NB8A Mk2 99-00

It’s a 0.4.3c Speeduino wiki says pin 1 is […]

Back feeding usb

Just curious has anybody had any problems powering[…]

Guess I got more done than I expected I would toda[…]

Still can't find what you're looking for?