Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
For any add-on boards such as VR conditioners, optos and OEM interface boards
#45476
Hi,

12v supply is stable and in battery voltage ADC pin is about 2.5v.
in debug is supply in volts?
software is unmodified BL49sp as is schematics,
only used nanolambda kicad file as a base beacuse cj125 was ready there.
What i understand is only things needed to move on from preset is that supply voltage is in allowed range and cj125 responds that all okay. and in debug there should be cj125 hex code, that tells what its state is, but it reads only 0, so could it be that cj125 is somehow not responding at all?
#45494
Hello JKS17,
There must be something wrong with your hardware.
You must confirm first your analog input (A0 for the voltage divider of Ubattery) is reading the voltage properly. You can check this out really easy with a small sketch like this:
Code: Select all
void setup() {
  Serial.begin(9600);
}

void loop() {
  int sensorValue = analogRead(A0);
  float voltage = sensorValue * (5.0 / 1023.0);
  Serial.println(voltage);
}

The firmware won't do anything if the assumed voltage of your powersupply isn't in a valid range.

Best regards,
Chris
#45496
Thank you for the help, Chris.

I uploaded test code and serial monitor is like as pin was floating,
i pulled it to 5v, but no change in serial monitor. i uploaded same test code to spare nano,
and it was working fine when pulled to 5v. I then tried to switch analog pin to see if it change something,
but same result.
Only thing i can think of is that mega328p is internally damaged,
which is quite odd because both boards i have tested have been same problem.
Attachments
voltage problem serial.PNG
voltage problem serial.PNG (11.37 KiB) Viewed 1329 times
#45500
Hello,

at your test have you had still the 12V connected?
Because with 12V voltage divider the code from chris won't show the real voltage.

Try the following test code,this would give you the real supply voltage
Code: Select all
void setup() {
  Serial.begin(9600);
}

void loop() {
  int sensorValue = analogRead(A0);
  float voltage = (float)sensorValue * (24.5  / 1023.0);
  Serial.println(voltage);
}
#45501
Yes, 12v was connected, and even with wrong formula for voltage it would have to show something, but no change in serial monitor.
I try take one mega328p from nano that i know for sure is working, and see if it fix the problem.
#45508
Finally get it working, sort of.
i jump wired nano in the board :roll: ,
and now serial monitor is as it should be.
i still have no idea why it didnt work in the board,
i added screenshots if someone can spot a mistake.
maybe next time is better to make just a shield for nano lol :D
Attachments
no problem serial.PNG
no problem serial.PNG (14.67 KiB) Viewed 1298 times
pcb front.PNG
pcb front.PNG (244 KiB) Viewed 1298 times
pcb back.PNG
pcb back.PNG (245.82 KiB) Viewed 1298 times
#46403
@EdGi :
Of course you can have the fabrication files for the controller.
You can download them from GitHub: https://github.com/oelprinz-org/BL49SP/ ... on/V0.0.2a
The BOM is corrected to the actual date. With this 3 files you can order 10 almost full assembled pcbs at Jlcpcb.com for something around 86 $. Five full assembled pieces would cost 73 $, so this doesnt make any sense. You only have to solder the CJ125 on it and the Varistor R23 (but it works also without it).
My last order of 10 assembled pcbs was around 95 Euros shipped and all taxes/duties already paid to Germany.

Needed Connectors and Pins are Molex Mini-Fit Jr 5569 :
1x Pin Header 2x4P: 3930-1080
1x Pin Header 2x3P: 3930-1060
1x Contact housing female 2x4P: 3901-2085
1x Contact housing female 2x3P: 3901-2065
14x Crimp socket Female: 3900-0039

I haven't done more tests on them as i was moving in the last weeks. But i have sent two pieces to a good friend of mine which is known as a "lambda assassinator". If they will work there and survive it they should work fine for everybody. ;) When i got some more news i will inform you here in the forum.

Best regards,
Chris
  • 1
  • 14
  • 15
  • 16
  • 17
  • 18
  • 21
Kawasaki Concours 2.0

Having second thoughts about cutting a hole in my […]

I finally think I have almost crossed another hurd[…]

Weird TPS+voltage problem

it could be corruption in the tune. Can I suggest[…]

I did pull the alternator off just to rule that ou[…]

Still can't find what you're looking for?