Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
Any general discussion around the firmware, what is does, how it does it etc.
By noisymime
#22968
Not going to lie, the November firmware has been a struggle to get ready to roll! There's been a HEAP of work done around a big new feature (See blow) and it has taken me far, far to many nights getting this all sorted. The gear news though is that it's all set and ready to go!

Without any further delays... The big new feature this month is all around staged injection! Many people have been asking for this for quite a while now, so I'm really glad to be able to get this release out with it finally in place. Staged injection is currently available for 4 cylinder and rotary engines, with support with other configurations being possible in the future if needed. The staged injection works in one of 2 ways:
  • Via a standard 8x8 3D split map that outlines what % of fuel should be delivered by each set of injectors
  • In an automatic mode where the system itself takes care of the injector split. This system uses the complete fuel model and means that a user only need to tune the VE table as they would normally and the injector split will be managed by Speeduino.
This should be considered slightly experimental for this month Everything appears to be working as expected, but there have been some HUGE changes in the code to enable this, so it's possible something else got introduced in.
  • Fix for a critical fuel issue when using Simultaneous fuel mode
  • Multiple fixes on the stepper idle system. This was previously not homing correctly and may have failed to operated as expected after homing.
  • External Baro sensors now have their own calibration (Had previously been shared with the main MAP sensor)
  • Fix for an issue in the newer TunerStudio betas that prevented them reading the ini file. The file encoding has been changed on the ini file to operate with these newer TS versions
Given the nature of some of the bugs that were fixed in December, I would strongly recommend this upgrade for all existing and new users.
https://speeduino.com/wiki/images/2/24/ ... -Nov17.zip

As usual, if any issues are discovered, please comment below and I'll look at them immediately.
By stum
#22976
Good stuff.

You have said only 4 and rotor for now.

Would it work or be configed for a v6 with the 4th (currently unused) channel driving an injector or 2 as extra fuel in the plenum. Just looking to boost my V6 (currently running a speedy) and would mean I could keep the existing injectors and add 2 for the top end.

Just a thought. thanks
By noisymime
#22977
stum wrote:
Sun Dec 10, 2017 10:04 pm
Good stuff.

You have said only 4 and rotor for now.

Would it work or be configed for a v6 with the 4th (currently unused) channel driving an injector or 2 as extra fuel in the plenum. Just looking to boost my V6 (currently running a speedy) and would mean I could keep the existing injectors and add 2 for the top end.

Just a thought. thanks
That's not a bad idea and is very simple to add in. I'll have a look at it for this month.
User avatar
By Sakisteve
#22986
noisymime wrote:
Sun Dec 10, 2017 11:58 am

[*]Multiple fixes on the stepper idle system. This was previously not homing correctly and may have failed to operated as expected after homing.
what type of homing movement, should i be looking for on this on power up? should motor step out to home (closed position) and then step back a step (open for idle)? Just wondering what i should be looking for as i'm getting a step out towards home, and then after that another step out towards home. Trying to diagnose if hardware or software setup issue. I don't believe it to be hardware, i think i must be setting something up wrong in TS. Im using a Simple Screw in GM 4 Wire Stepper. I did upgrade to the new Firmware and now I'm getting 2 step movements vs only 1 step movement on the old firmware.
By noisymime
#23002
Sakisteve wrote:
Mon Dec 11, 2017 2:59 pm
noisymime wrote:
Sun Dec 10, 2017 11:58 am

[*]Multiple fixes on the stepper idle system. This was previously not homing correctly and may have failed to operated as expected after homing.
what type of homing movement, should i be looking for on this on power up? should motor step out to home (closed position) and then step back a step (open for idle)? Just wondering what i should be looking for as i'm getting a step out towards home, and then after that another step out towards home. Trying to diagnose if hardware or software setup issue. I don't believe it to be hardware, i think i must be setting something up wrong in TS. Im using a Simple Screw in GM 4 Wire Stepper. I did upgrade to the new Firmware and now I'm getting 2 step movements vs only 1 step movement on the old firmware.
This sounds like the intended behaviour. On power up the motor should home itself and then move into the requested idle position.
By M.Itani
#23007
with the new firmware my idle valve (7mgte) homes to full open (so very high) then in closed loop it slowly closes the valve to keep the demanded RPM! makes me believe its working fine ! until now i only bench tested with CPS and a drill and all seems to work fine ! when i get the chance to take my car out the garage ill see if it works in practice
By mattsabun
#23009
M.Itani wrote:
Wed Dec 13, 2017 2:03 am
with the new firmware my idle valve (7mgte) homes to full open (so very high) then in closed loop it slowly closes the valve to keep the demanded RPM! makes me believe its working fine ! until now i only bench tested with CPS and a drill and all seems to work fine ! when i get the chance to take my car out the garage ill see if it works in practice
you're using 24/1 trigger wheel right?

1J and 1Q appear to be jumped at all times (with i[…]

Speeduino ECU compatibility

Speeduino works with any engine. You just need to[…]

Please read the wiki. It seems you don't understa[…]

VVT angle going backwards?

Pretty sure other than MX-5 trigger VVT is still W[…]

Still can't find what you're looking for?