Second firmware live stream happening this weekend: viewtopic.php?f=13&t=3992
For anything you'd like to see added to Speeduino
User avatar
By lwoodward96
#40612
Hi Again!
My Triumph Stag is still running well on my EFI conversion, and the November firmware's inclusion of idle ignition advance settings has allowed me to smooth the idle, especially when going from park/neutral to drive/reverse on the gearbox. The characteristic drop in revs when engaging gear has gone from 1000 down to 700rpm, to 900 down to 800rpm.
However, when slowing down to a stop, as the engine speed drops below the threshold for idle, it switches immediately to the idle advance settings. This results in a very quick drop in rpm.
Would it be possible to ramp it from map to idle? Rather than an immediate switch?
Alternatively, if anyone can provide some info on implementing a PID (or just PI) function for idle advance, even if it's just in code rather than through tuner studio, I'd be grateful!
Thanks, Lawrence
By Ilotalo
#40646
lwoodward96 wrote:
Thu Jan 30, 2020 6:45 pm
Hi Again!
My Triumph Stag is still running well on my EFI conversion, and the November firmware's inclusion of idle ignition advance settings has allowed me to smooth the idle, especially when going from park/neutral to drive/reverse on the gearbox. The characteristic drop in revs when engaging gear has gone from 1000 down to 700rpm, to 900 down to 800rpm.
However, when slowing down to a stop, as the engine speed drops below the threshold for idle, it switches immediately to the idle advance settings. This results in a very quick drop in rpm.
Would it be possible to ramp it from map to idle? Rather than an immediate switch?
Alternatively, if anyone can provide some info on implementing a PID (or just PI) function for idle advance, even if it's just in code rather than through tuner studio, I'd be grateful!
Thanks, Lawrence
I have fight with these problems and i have tweaked ecu code from these parts.

For that idle load change i have simple solution to adjust idle so it stays in right idle speed. Simply if rpm is under threshold +1 to idle and if it's over -1. In my situation it's working well.

That slowing time problem i have done more coding. I have logic how it opens valve if rpm or MAP is high. If i decelerate idle closes slowly. When decelerate stops it starts to control that simple adjust.

I have done delay for deceleration and idle advance setting so it goes more smooth from deceleration to idle.

Now i have driven car month whiteout done any new code for it. I think it works well. And i open that idle valve in cranking at max so i don't need press gas pedal when i start.
No ckp signal

No sync so nothing to speedy. You can put in some […]

But still it seems like the sync loses are relat[…]

Startup Jaguar V12

If you haven't tuned the cells above idle yet, I'd[…]

I know it's almost been a year, but I thought I wo[…]

Still can't find what you're looking for?