New wiki and manual has launched! Check it out at http://wiki.speeduino.com
Any strange behaviour, crashing issues etc, post them here! Problems compiling the firmware should go in the General support section rather than here
User avatar
By marciohiteck
#41696
Hello people!!
Today updating my system (Linux Mint 19.2) I came across the following situation with SpeedLoader, the list of firmware, data "msq default" does not appear, let alone the port assigned to Speeduino. Question ... Is there a problem with the file server ??? Or am I doing something wrong ??? Any help will be welcome. Thank's...
Attachments
SpeedLoader.png
SpeedLoader.png (426.95 KiB) Viewed 254 times
By noisymime
#41713
Hmmm possible there was a server hiccup or something at the time. Everything certainly seems to be working OK for me at the moment.

If you have the issue again, try loading https://speeduino.com/fw/versions in a browser. If that loads in a browser, then it's something to do with connectivity in SpeedyLoader. If the page doesn't load, then it's a server (or location connection) issue.
By Black Knight
#41735
I had a similar issue. I am using linux mint.

I may have the fix??????
Not sure.

It turned out being a command that assigns the port on linux command line. It is as if TS port assignment and linux are not talking with each other. The port worked for all other uses but not TS.

There is a linux command that worked for me.

I can not find the commands in all our notes. I will try to find the fix to help you.
I need to make notes on this anyway.

Try looking up on line: USB port not connecting for linux mint or Ubuntu.

If I find it first I will post here, you do the same if you find it first.

I do have the instructions for making a desk top icon if you need it.

Linux has it's traps but can be fixed.

I am very limited with linux.


Black Knight
By Black Knight
#41738
I think I found the info. Hope it helps.

I had problems with TS and speedy loader because of this.

I had to do a command history on linux to find it. I have never done that before.
Kinda cool.

It has to do with the command chmod for serial ports.

I hope this link works for you to point you in the right direction.

https://askubuntu.com/questions/58119/c ... port#58122

You may also need to make sure your java is installed correctly. I had some issue with that too.

Linux has its own challenges with TS and speeduino.

I never did try speedy loader after this fix but it did let the firmware and TS find the serial port.

Good luck.

Black Knight
User avatar
By marciohiteck
#41745
Hello people....
Thanks for the answers, but I solved the problem ....
Just out of curiosity and maybe someone will experience it ..
I looked at the old Speeduino Wiki and downloaded the SpeeLoader App image and it worked fine, but the procedure via the Linux command terminal mentioned in the installation method did not work, I realized via debug that SpeedyLoader crashes even before loading data after the command " npm start "it freezes on this screen up there, but as I had a HD from a Linux Mint 19.1 installation and with SpeedyLoader already installed there, and working, I decided to copy this folder and transfer it on my current system, and it worked as it should. My guess ... I think a new version of Node.js with some module or plugin causes the problem. When the permissions of the serial ports were changed, "sudo usermod dialout -a -G $ user" still did not solve it. Something to be investigated ....
I repeat ... AppImage SpeedyLoader works. Thank you all, I hope I have helped you in some way.
Attachments
Captura de tela de 2020-03-27 16-34-05.png
Captura de tela de 2020-03-27 16-34-05.png (388.51 KiB) Viewed 114 times
By Black Knight
#41748
Good to hear you solved the issue. Thanks for the feed back.

As I am limited wit Linux it seems I was not able to help you much. No worries.

I don't know if this is related?????

I have a system that uses Puppy linux for on line Internet work and It can not access the new speeduino manual from the speeduino forum. I can get in to it if I go directly to the PDF on line with no issues.

Maybe a link issue for Linux users????

Again, this is not an area I have a great deal of knowledge with so I may be off a little here.


Later

BK

I think the main challenge here will be controllin[…]

R1 Thunderace trigger

Apologies for raising this old thread, but those a[…]

This should now allow 6 and 8 cylinder semi-seque[…]

Pin 7 is the mega pin, not the pin on the 40 pin c[…]

Still can't find what you're looking for?