Second firmware live stream happening this weekend: viewtopic.php?f=13&t=3992
Any questions you have before you begin buying, building and installing.
User avatar
By zoidberg
fixed it.
i remapped the pin to 39 and pulled the pin 38 from the header. Means i am not on vanilla but that is ok.

I also had the problem that the Programmer headers where doing short circuits on the board.
Now it works.
User avatar
By zoidberg
LPG2CV wrote:
Thu Mar 12, 2020 8:42 pm
Try init.ino
Line 1004
pinO2 = A8; //O2 Sensor pin ??

Line 1077 is relevant for what i did.
Something is messing with the pin 38.
This doesn't apply for != v0.4 these have other pins set. We have tested V 0.3.
We also have tested a simple blink programm for arduino and it worked with pin 38. I suspect something going wrong with pin 38. Maybe its cursed.
User avatar
By zoidberg
My soldering is fine.
I still believe i found a bug here, i will have to bisect this and find out which commit causes the problem with pin 38. Because the Pin 38 problem persists even without any shield on the arduino. This is why i went to using pin 39.

The short circuit problem is diferent, as it was only persistent on the shield arduino combination when the arduino was plugged in all the way. I'm really happy i found that problem before it was in the car, as that would have been a pain to debug.
If there was a bug that stopped ign channel 2 from working, then everyone would have it!

So, what are you doing that is different to other users?

Perhaps describe your setup and post your tune
User avatar
By zoidberg
LPG2CV wrote:
Fri Mar 13, 2020 9:44 am
If there was a bug that stopped ign channel 2 from working, then everyone would have it!
Yes i mean everyone using 0.4 with the latest firmware.
I loaded the basetune but that shouldn't matter. I have an arduino mega: ... UTF8&psc=1

I flashed the latest firmware and connected a LED to pin 38 directly (with a resistor to gnd not to kill the LED).
Then I connected it to tuner studio selecting the 0.4 board.
Then i used hardware testing to set the output on pin 38 to high which doesnt work.
works for all other pins.

When poweriung the arduino pin 38 flashes a few times. That tells me that there is something happening with that pin, maybe there is a register shifted so that this pin goes high and then low and cannot be used later because of that. Who knows. I will have time to bisect that this weekend.
Perhaps load the previous fw version and run the test again.

Another thought is to clear the eeprom and reload the fw. I had to do this my self when I had a bridge across from 5v to gnd. The short sent spurious values to the tune when saved. I thought once I have resolved the bridge, just reloadind a new base tune would resolve it. But it didn't, and I spent more time looking for bridges. Eventually, clearing the eeprom, and loading a new base tune resolved it.

Not to time consuming to try it. :D

@Stum So I got out there today and started to cra[…]

I fixed the timing problem, it has no jitter now. […]

New 202005 firmware

is it possible there's something particular in you[…]

Yes although a simple trigger for fuel only will s[…]

Still can't find what you're looking for?