Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
Any strange behaviour, crashing issues etc, post them here! Problems compiling the firmware should go in the General support section rather than here
By LPG2CV
#47633
Is it feasible to unplug the board from the mega and test the mega output pins for ignition. That is testing the system halfway through as it will prove/disprove functionality for the mega, tune and fw.

I had a similar issue a while back, where I had a short in the wiring in the engine compartment. The engine faltered and then failed completely.
I did have leds stuck on, and I think they were ignition as I wasn't running fuel at that time.
In the end the solution was to use a new mega (old one damaged) which in the end I ran eeprom clear. A complete new base tune that I re keyed the configuration in . I think both tune and mega were corrupt. Even then, I had to turn it on and off a few times!
By Gshorten
#47635
This is a bit wordy, sorry, just trying not to miss anything:

Removed speeduino from Arduino. Used JimStim to send 5v crank signal to pin 19 on Arduino. On pin 8 (Inj 1) I get a nice clean square wave. On pin 28 /24 (ign 1,2) I get nothing at all. I have not changed any settings in tuner studio. I rechecked all settings, compared with old tune that I had when engine was running well. No difference. So, I tried different Arduino. Same. Obviously I'm set up for wasted spark, semi sequential. trigger settings correct because I'm getting good injector output. I disabled engine protection, in case spark was being cut.
Maybe, pins 28/24 on both arduinos are bad? So I wrote a sketch to test - I get perfect square waves out of both pins.

BTW, in hw test mode I get signal on the injectors, nothing on ignition.

For the last tests I uploaded the latest firmware (Dec). In Engine Constants I have Board Layout set to v0.4. So, I change this to v0.3 - NOW I get ouput from the ignition channels from the Arduino. I connect the Speeduino back to the Arduino (still on v0.3), no output on the 40pin connector ignition pins. Am getting ignition signal at the connection to the arduino. Injectors working so it's not the trigger. Solid 5v continuous on all ignition outputs (at the chips and on the 40pin), So still points to something bad on Speeduino board - BUT ALSO something amiss in firmware, seems like the v0.4 Board Layout setting does not work. BTW I have a schematic for the v0.4 board, am using pinouts as on the schematic for testing.

Probably when the car was running it was set up (pre december) for 0.3 board, when I updated firmware it got set to 0.4, so loss of signal from arduino was unrelated to loss of spark from Speeduino board. At this point I wait for new Speeduino board, see how that works.
By theonewithin
#47637
There won't be anything wrong with the 0.4 setting.

If there was there would be hundreds of people with issues.

Try eeprom clear and load base map and not yours at all and check again.

It's sounding more and more like either firmware corruption or a problem with the tune somewhere.
By Gshorten
#47733
OK, I cleared eeprom, new firmware load, started with the base map. bare Arduino, no speeduino board. crank signal from JimStim.
with Engine Constants/Board Layout set to v0.3 I get nice square wave for injector outputs(pin 8) and ignition outputs (pin 28).
With Board Layout set to v0.4 I get signal on injector output, nothing on ignition output. I've tried multiple arduino, same result.

Schematics for v0.3 board and v0.4 board show that the pinouts are the same.

still waiting for my new speeduino board to see if that fixes the ignition output problem.
By Gshorten
#47735
ok, I am an idiot. Ignore last post.
Ignition outputs are different between 0.3 and 0.4 boards.
ignition 1 is on D40 for v0.4, its on D28 for v0.3

at arduino level everything ok. will see what happens with new speeduino board.
User avatar
By PSIG
#47737
You are correct (without saying so) that there are errors on some v0.4 schematics that show the individual circuits (e.g., ignition) with v0.3 Mega pin connections that are incorrect, and the Mega pinout section on the same sheet that shows correct pin assignments. It is confusing or frustrating, and you're not the first. Glad you found the schematic error before pulling more hair out! :lol:

Now that you know the correct pins to test, are they working on the Mega? If so, now you know it is a board, soldering, or component failure, which is easy to track-down with a 'scope or VOM. I would check the old board.
By Gshorten
#47856
Update. Received my new speeduino board. On the bench it is working properly, I have nice square wave on IGN 1. With old (failed) board I had no input on pin 2 of the TC4424, even though there was input from the Arduino on D40. So somewhere between D40 and input 2 on the TC4424 it was open. Now i've got the 5v input on TC4424 pin 2, 5/12v output on pin 7.

It's -20c here in Calgary. When it warms up a bit I'll put in car and start up. I'll check to make sure there is not a short on the coil input(s) but even if there was this should not kill the TC4424, @ 12v through the 160 ohm resistors on the outputs a dead short is only 80ma, the TC4424 is rated for 3amps out.

So, don't know why old board failed. I'm assuming user error but don't know what I could have done. Consider this thread closed.

Simple diagram for 2ch Bosch 200 ignitor

CLT sensor wrong reading

Once again as above. You need to find and fix you[…]

Kawasaki Concours 2.0

Going bonkers trying to wire up a Bosch LSU4.9 to […]

3 cylinder 2 stroke controller

Quick update. New 0.5 ohm coils and the Bosch 211[…]

Still can't find what you're looking for?