Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
Help with building your Speeduino, installing it, getting it to run etc.
By zataviou
#46273
hello

I have put a speeduino on my yzf 125, this is a single cylinder four stroke engine without cam sensor. I would like 1 spark every rev and 1 injection evry rev, how configure it in tuner studio?


This is my actual configuration:
spark.png
spark.png (26.81 KiB) Viewed 933 times
CONSTANT.png
CONSTANT.png (35.34 KiB) Viewed 933 times
Is it ok ?

My bike does not want to start, it seems very close to start but no :evil:
Yesterday it started but today nothing


i'm french, excuse me for the mistakes and i hope you can understand me
By LPG2CV
#46276
Welcome :)

2 squirts per cycle. And, i think wasted spark Should do it.
When you change to two squirts, look to see if the required fuel halves.

Post your tune, and a log of you tryingbto start it based on that tune. :)
By zataviou
#46285
if I put 2 squirt required fuel is set to 0

you can find my log and the configuration file in my .rar

in log file i can see a positive value for"sync loss" does it mean there is a problem with my crank sensor ?

thanks
Attachments
(10.35 KiB) Downloaded 35 times
By LPG2CV
#46291
im seeing a very odd VE table! Cells to 5200 rpm are 28. Is that what you have?

Do you have an O2 sensor and controller?
By LPG2CV
#46295
Best to load a base table provided. You can download a zip from speeduino github. There are base files in the reference folder.
You will need to replace the spark table. Search for megasquirt spark table generator on the web.
Once you've load the base tune, generate spark, afr, and ve tables. Go through all the settings.

That should able you to start the engine.


Let us know how you get on. :)
By zataviou
#46473
I loaded the bases ve table and it started!

I have always a problem , the fueling is very bad (i can not open the throtle more than 5% and more tha 4000rpm)

I have reused the oem map sensor and I am not very sure about his calibration, I will buy a mpx4115 to be sure and compare.

thanks for your help
By theonewithin
#46506
Congrats!

You have the engine running.

Now you need to actually tune it.

You will not find a tune that you can load and it just works.

You have to tune it.
By zataviou
#46514
For sure I have to tune it, but before I want to be sure that my sensors works properly.

It is the first time I work on a fully programmable ecu and I don't know how it should be working

to understand, if I have a VE of 50 and a "required fuel" of 8.2ms that means I will get a PW of 4.1 ms (or 2.05ms for non sequential) ?

you have the tune and log in the attached file
Attachments
(43.45 KiB) Downloaded 27 times

Simple diagram for 2ch Bosch 200 ignitor

CLT sensor wrong reading

Once again as above. You need to find and fix you[…]

Kawasaki Concours 2.0

Going bonkers trying to wire up a Bosch LSU4.9 to […]

3 cylinder 2 stroke controller

Quick update. New 0.5 ohm coils and the Bosch 211[…]

Still can't find what you're looking for?