Any strange behaviour, crashing issues etc, post them here! Problems compiling the firmware should go in the General support section rather than here
By Fatman
Hi everybody, I have a really odd issue which appears to be completely unique to me.. I posted directly on the firmware release page but had no responses so I will copy and paste it.

Hello, I am absolutely loving Speeduino so far! I have been using a speeduino 0.4.3c in my Clio 1.2 turbo for 6 months or so. Had to make my own fly by wire controller which is a bit crude but works well enough for me.
I have an issue with the new firmware, in that tuner studio does not want to connect to it at all.

I usually download the arduino code and upload it and then add the .ini file to the tuner studio project.
This time it came back that the firmware version on the arduino was SP (whatever that means) but I added the .ini file anyway
It then failed the communications test and point blank refused to connect once the project was opened.
I tried this again with the same results and also re downloaded the firmware just in case. Also re installed tuner studio

I then decided to try using speedyloader, used the .ini file it downloaded. The results are largely the same except I noticed tuner studio looked like
it was trying to connect and failing (the progress bar came up and froze). I also noticed the
injectors buzzing away. I suspect that for whatever reason serial comms were being made and broken rapidly and the arduino was resetting continuously. After this I tried many things including creating a project from scratch, restarting the computer a few times also there were no further attempts made by tuner studio to connect.

After this I gave up and re uploaded 202002 which works flawlessly.
I have talked to my friend who says he has updated 2 cars with no issues..
So really I am at a bit of a loss with how to attack this next.
I should also say, this us using USB not bluetooth.


An update to this is, I tried communicating with the arduino via serial monitor in the IDE. With 202002, found the line which deals with printing the firmware version (send Q) and it replies with the firmware version as expected.

With 202005 installed I get nothing back at all, but the injectors are still buzzing like crazy and if I had the fuel pump connected it would be on constantly on spraying fuel into an engine which isn't running. I honestly think its somehow getting stuck in the priming routine somehow.

If anyone could help with this it would be amazing, anyhow thanks in advance!
comms3.png (189.3 KiB) Viewed 642 times
comms2.png (186.94 KiB) Viewed 642 times
comms1.png (177.97 KiB) Viewed 642 times
By noisymime
The 'SP' you're seeing in the signature is simply the first 2 characters in the full signature ('speeduino-202005'). This makes me think that for some reason the comms is being interrupted after reading just a couple of characters.

You don't have any other software running in the background that might be trying to connect to the arduino at the same time by any chance?
By Fatman
Thanks for replying!

No sadly nothing else in the background.. I do wonder if I have a slightly strange board, because my boost control pin is pin 6 (going to pin 35 on the IDC).

I am going to try using another laptop this evening but I doubt it will help. The next move was to get a clone of an arduino Mega, and upload it to that. Because of access reasons I dont want to remove the arduino from its box.

I guess if that works then there must be something funky going on on the board..

I will let you know how it goes tonight anyway!
By Fatman
So my friend tried with his laptop which has successfully uploaded 202005 to various cars and tuned them. No difference,

Then tried it with the engine loom disconnected and it still couldn't communicate. Have also tried a different, much shorter usb cable with the laptop resting on the engine. So the issue is either being caused by the genuine Mega or the 0.4c board..

The kit I bought was off ebay ... Sw1ZpbCrTz .

Tomorrow, I guess I will have to open up the ECU and disconnect the Mega from everything else and see if tuner studio will talk to that on its own. I'm kind of hoping it doesn't because that means the issue is with the Mega rather than some untraceable fault.

Anyway, I will let you know tomorrow!
By lsdlsd88
is it possible there's something particular in your tune (msq)? have you tried loading the for example the 202002 base tune and then updating to 202005 ?
By noisymime
Are you running the Arduino pictured in that eBay auction or another one? Just that the eBay one looks to be a CH340 serial board rather than a proper 16U2 one.
By Fatman
So sadly, I have taken the ECU out and disconnected the Mega from everything.. it works.

Have just tried bending the reset pin, RX0 and TX0 out so they don't go into the headers. No different! Also it isnt the same as the Mega in the picture, it definitely has the 16U2 serial chip

I am currently in the process of trying to connect some of the pins at a time. I have established that, if you have the serial side of the board connected (at an angle) when you open tuner studio it connects. Then sometimes it carries on working as you steadily reintroduce the rest of the pins, sometimes it stops working.

But still don't understand why different firmware would have made this a problem... If I find anything Ill let you know.
By Fatman
So.. this gets even weirder.. I have found the pin causing the issues.. A2 the TPS I believe? But why? I mean I get a lot of weird faults, but even by my standards this is really quite odd!!

So I found the fault with 3 jumper cables. 5V, GND and another which I was methodically moving along the pins on the board between disconnecting and reconnecting the USB cable.

The other weird thing is, if I plug in the USB without A2 connected, wait for serial to start, then re connect A2 it carries on working.. Anyway I will try with another Mega tomorrow. My friend has one that I can try, although I think it might be a clone.
By Fatman
One final little update because there is nothing else I can do. I am 99% sure its the Arduino at fault. If I ground A2 without the shield board connected and plug the usb in it will not connect to tuner studio.. But if I connect the usb, wait a few seconds, then ground A2 it carries on working. Also the TPS gauge in TS works as it should..

I doubt the mystery of why it works with the old firmware will ever be solved, but I am fairly confident a different Mega will fix everything.

Will let you know when I know!
You could try clearing the EPROM. You may have a spurious value or corruption in there somewhere.
Turbo dodge 2.5 minivan

Actually there is one critical issue. The stepper […]

Rb20det tps wiring

Have you referenced a factory service manual for p[…]

Thanks Dwight! yes, I have the speedy sensor grou[…]

UA4C: Fuelpump not working is working now... What ended up being t[…]

Still can't find what you're looking for?