Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
For anything not related to Speeduino, but still about car/bike/boat/engines etc
User avatar
By Bleeker
#36268
Hi all,

I have a CDI from a 125cc 2-stroke Yamaha which is not working anymore and thought you guys could maybe help me to fix it.
I have checked the Ignition Coil, Pulser Coil and Source Coil of the system, they all seem to be ok, but I have no spark, so it must be the CDI.


The original Spare Part costs a fortune and if I buy a used one, it’s still quite costly without guaranty on the function.
A programmable aftermarket CDI system is again expensive and I don´t want to spend time on tuning the ignition curves.

Therefor repairing the damaged CDI is my preferred solution at the moment.

As the pre-owner already started to remove the potting compound, I finished his work:
20190707_215058.jpg
20190707_215058.jpg (690.14 KiB) Viewed 3297 times
20190707_215051.jpg
20190707_215051.jpg (241.68 KiB) Viewed 3297 times
20190707_215043.jpg
20190707_215043.jpg (515.8 KiB) Viewed 3297 times
Unfortunately the PCB was already damaged on one corner:
20190707_215102.jpg
20190707_215102.jpg (287.51 KiB) Viewed 3297 times
But I don´t think this will impact the functionality.

I already checked the diodes and capacitors with my limited equipment (multimeter) and I´m quite confident that the diodes are ok but not sure on the capacitors.

So my plan at the moment is to just replace all 7 Capacitors on suspicion, as they are not very costly anyway. Is there anything else you would recommend me to order and replace?
Maybe Transistors? Unfortunately I can´t see any description on them.
Or the Thyristor? There I have the type.

Is there anything else which typically goes wrong on such CDIs?

When I looked at some circuits for CDIs before disassembling mine, I thought they would be quite simple, but there are a lot more components on mine :cry:

Thanks for your help !
User avatar
By PSIG
#36272
Bleeker, you are correct, that CDI is relatively simple. What makes yours complicated is the built-in custom timing and function controls. Obviously, it has sustained extensive damage, with greater concern for the magic contained in the control chips than the (relatively) easily-replaceable discrete components.

My approach would be to clean everything very, very well, especially well under components and behind legs. Identify or simply replace obvious components (I see at least one destroyed capacitor) with carefully selected replacements of equivalent or better spec's and quality. Test the entire board and all connections for continuity of solder joints and for possible shorts or conductive tracking. As I cannot suggest methods for testing the function of the magic chips, at that point I could only suggest trying it.

David
User avatar
By Bleeker
#36296
LAV1000 wrote:
Tue Jul 09, 2019 3:21 pm
Check out is this one:
https://transmic.net/shop/
Is been around a few years.
This looks interesting indeed, but it seems like there is no readymade option for YPVS (Exhaust Power Valve) control unfortunately. On my CDI it seems like it just sends a rpm signal to the YPVS controller. This signal is taken from the charging line of the big capacitor.
I think I could branch this off from the transmic CDI as well. But actually I´m looking for a quick and easy fix and don´t want to Jump on another project like Speeduino.
PSIG wrote:What makes yours complicated is the built-in custom timing and function controls.
Yes, the CDI is also used for Sidestand, Oil Level, Neutral Lamp and YPVS output.
PSIG wrote: ... carefully selected replacements of equivalent or better spec's and quality.
David
I´m planning to order following caps and give it a try, would this spec for the caps be OK:
Elko, radial, 0,47 µF, 50 V, RM 2,0, 85°C, 2000h, 20%
Capacity and Voltage is clear, but I´m not sure on the other values.

Thanks.
User avatar
By PSIG
#36300
Bleeker wrote:
Wed Jul 10, 2019 8:06 am
I´m planning to order following caps and give it a try, would this spec for the caps be OK:
I have no idea, not knowing what the spec's are for the original caps on the board. My suggestion would be to look those up and compare against that. Minimally capacity and voltage of course, but also close values or better values in other aspects (ESR, leakage, etc) if possible, for the best chance it will work as originally intended. That's up to you and your choice.
Image
David
User avatar
By Bleeker
#39183
Hi,
unfortunatelly I was not able to repair the OEM ECU, so I decided to go for the transmic CDI.

The PCB is ready now but I´m struggling with the Programmin via PICkit :(
When I was reading the description it sounded straight forward but somehow I always pick up the issues.
I just realized now how user friendly Speeduino actually is...

Would be great if there was a CDI option for Speeduino, I mean not only the coil output but also the single tooth trigger logic. But as this would also require a different hardware setup, that would not have much to do with speeduino I guess.

Is there accidentially somebody arround who can help me out with the PICkit Programmer?
By LAV1000
#39189
Bleeker wrote:
Fri Nov 22, 2019 10:20 pm

The PCB is ready now but I´m struggling with the Programmin via PICkit :(
When I was reading the description it sounded straight forward but somehow I always pick up the issues.

Is there accidentially somebody arround who can help me out with the PICkit Programmer?
They told me several times that I am also the only one having troubles PC and software related.
I don't believe them any more. :D
PNP, doesn't stand for Plug and Play, but Plug and Pray.

I don't know if I can help.
But what is the problem?
Can you post a link to the product and discription ?
User avatar
By Bleeker
#39209
I try to use PICkit3 to programm a PIC16F628A.
When I connect the programmer, the Software tells me that the connection to the programmer is ok, but I can´t connect to the PIC.
I always receive the error message "device not detected"
I tried options like VDD on, MCLR on, Use VPP first entry but nothing helped.

Seems like the PIC does not enter programming mode?
L TWIN ducati vr signal need help

As above a tooth log would be useful. Which condi[…]

Modified 3 cylinder

You would still need to remove the intake setup of[…]

In my experience the problem only usually occurs[…]

3rz-fe turbo. help with iac valve

READ THE WIKI. https://wiki.speeduino.com/en/conf[…]

Still can't find what you're looking for?