Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
Help with building your Speeduino, installing it, getting it to run etc.
By LPG2CV
#46517
your ignition table needs replacing as it appears up side down.

you can generate a new one here more suitable for your engine characteristics.

http://www.useasydocs.com/theory/spktable.htm

also, download Megalogviewer. connect it to you tune, and have a look around the application. come back if you need help. :) it will help you understand what is happening with fuel etc

ignition table first. :)

The VE is a percentage of the RF. Its just maths. As a guide, you are looking for a VE at idle somewhere around 30-40. However, it is not critical.
Strat tuning with it warmed up and try to get a stable idle. Then work up from there.

Logs are you friend :D

let us know how you are doing. Always post logs with the tune that was current when you took the log.

your doing well
By zataviou
#46714
Hi

I come back with some information and log about my problem!!

-First, I have made a mistake with the calibration of my map sensor (I compared with a mpx4250) now this is ok

- I generated the spark table with your link

now I'm here:

I start the engine (cold) and I hold it at 3000 rpm (2° tps) it seems turn well during some seconds and suddenly it turn very bad, the rpm is unstable, the state change is instantaneous as an interrupter. You can see clearly the problem in the log. If i turn off the ecu and wait a moment, when I restart the problem is still there (ok for a few second and turn bad )
Sans titre.png
Sans titre.png (21.48 KiB) Viewed 752 times
I don't know if it's a software or hardware issue, I have found nothing in data log.


Do you have an idea of what happen?
Attachments
(22.24 KiB) Downloaded 35 times
By LPG2CV
#46715
Ive not looked at the log, but you probably need to look at after start enrichment (ase). Theres an enrichment part, and a duration part. There is also a taper value that is the transition time into warm up enrichment. :)
By zataviou
#46728
I don't think so, the ase transition is smooth and doesn't match my problem.

The U1 controller on the board is very hot is this normal?

I did another test this morning, same result: cry:
Attachments
(29.46 KiB) Downloaded 31 times
By LPG2CV
#46737
i think the voltage reducer can get hot, but im not familiar with your board.

post your tune with every log, as we dont know if you have changed it, and dont want to go back looking for it :)

it still looks like you are getting to much fuel. look at the gammae value when you look through a log.

check out the wue, and put some sensible values in there, as you should only be ending at 100%

post your current tune :)
User avatar
By PSIG
#46778
Please do another startup log/msq pair without moving the throttle. Your last one indicates rpm is increasing (better Lambda) but then the throttle is moved and we cannot see where it goes naturally. Then it appears to (possibly) enter lean misfire (fuel is reduced 144% from startup to stall), but it's tough for me to tell from that log.

Random stuff: Yes, the LM2940 voltage regulator can become very hot.
You are trying to start in running mode, as your cranking threshold is far below your cranking speed.
You have no Priming Pulse, but that's OK for now. Until you get a solid warm-idle tuned, you can't tune priming, cranking, ASE, or WUE effectively.
Yes you have sync losses while cranking, but it is stable during running, so keep an eye on it but not a primary running concern at this point except with misfires. Stop the misfiring and sync will probably be OK while running.
Watch your AFR numbers but do not trust them in the normal sense - they are only a reference that may be badly offset, or different than expected for your engine or fuel. Tune for best running results no matter what the AFR says, then use that best number (whatever it is) for a new target.
You may consider flattening your ignition timing in the area you are tuning, so it does not change as much, affecting running stability.
Try to stabilize your battery voltage as it is affecting actual fueling, or preferably consider entering better injector dead-time and voltage corrections settings. ;)
You have multiple little un-set or improperly-set values in your TS setup. While it will "run", little things such as those and the random stuff above can drive you crazy when you don't realize you're fighting them while tuning. Find and enter as many correct settings as possible to save frustration. :geek:
By zataviou
#47314
hi

After many tests I can say that my problem come from my crankshaft sensor!!

to find my problem I decided to work with 2 ecu, the oem ecu to provide ignition and speeduino to provide fuel.

We can now clearly see that above 5500 rpm it loose the sync.
sync loss.png
sync loss.png (19.44 KiB) Viewed 520 times
I played with the trigger filters, if I put to low or medium no change, if I put to aggressive, it’s perfect the engine works normally and I have no loss of sync.

After that, I tried to run the engine with speeduino only (fuel and ignition), it works well, but I can’t start the engine with the starter, it doesn’t seem to run fast enough (If I push the bike, it starts perfectly)

conclution with an agressive filter I have not sync loss and the engine run normaly but it must turn faster to start.

I think it's not normal to put the filter at its maximum, what can I do to improve quality of the signal?

I use a VR sensor with this conditioner (https://wtmtronics.com/product/dsc-dual ... tioner-vr/)


I measured the signal at the ecu at around 6000rpm Do you see something wrong?
20201227_180452.jpg
20201227_180452.jpg (5.74 MiB) Viewed 520 times
20201227_180542.jpg
20201227_180542.jpg (7.82 MiB) Viewed 520 times
my trigger configuration
trigger.png
trigger.png (29.78 KiB) Viewed 520 times
By theonewithin
#47328
Please post a tooth log why cranking from within tunerstudio.

Also you need to ensure you have selected the correct trigger edge for your conditioner as it needs to match your conditioner.

The tooth log can help indicate if you have the VR sensor polarity backwards.

What year miata is this? How do you have the injec[…]

EMI while cranking

Yes & Yes Very vague here, but as the injecto[…]

I finally start !!! It was all due to the degrees […]

ULN2803 output random cutout

Hello, I've got an output setup through the ULN280[…]

Still can't find what you're looking for?