Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
Any questions you have before you begin buying, building and installing.
By Egor
#46739
Hello everyone, I have a BMW E28 with an M20b20 engine, I assembled a speeduino 0.4 board, I want to use it only for fuel injection, the ignition distributor remains native, so I have a problem with the setting. I can’t start it, it starts to pour fuel from me, then it’s too little. could someone help me with the setup. in my city, no one has done this and can not help.
By LPG2CV
#46751
in engine constants, you select the board to be used. it defaults to 4.0, however, in the past, that hasnt stopped users changing it.

the symptoms you mention are common to having the wrong board selected. its just an elimination question. :)
User avatar
By jonbill
#46777
Your using the development firmware - you should probably use 202008 unless you've got a specific reason to use the dev build.
Also -
do you really only have 3 injectors? how are they laid out physically and electrically?
how have you connected your distributor to speeduino?
By LPG2CV
#46780
yes, as @jonbill suggests, use 20208 firmware.

The pin you have the fuel pump connected to, does not work with out a modification to the board . As you are not using VVT, its probably best to use the VVT pin for FP. So connect the FP relay ground to the VVT pin. Then, in Accessories, change the VVT pin to 45, and the FP pin to 4. If you do that, and key on, your FP should run for 6 seconds.
By Egor
#46790
Here's the startup log, but it never started. I have 6 injectors connected in parallel. the gas pump is connected to the native relay
Attachments
(5.2 KiB) Downloaded 15 times
Rover 36-1-1-1-1 wheel

Been out of the game for a while, but I'd be inter[…]

Chris, i told my ecu works on friends loom so i wa[…]

Twisting Wire/Twisted Pair

Connect the shield to earth / ground / negative at[…]

Nice! Does it make engine sounds? :D I always […]

Still can't find what you're looking for?