Page 23 of 24

Re: PCB for BMW m42/m50/m60 engine

PostPosted:Tue Jul 28, 2020 8:53 am
by kocene
Vauhtivaunu wrote:Also you should solder IC3 and all mosfets (Q1-Q10) in place.
I am using wasted spark mode, not sequential. So according to BOM, this is not necessary.

To be safe I uploaded the 202005 version to the board (attached the tune down below), but the problem still occurs.
pazi88 wrote:Do the injector leds work in HW test mode?
I just tested this and unfortunately, they don't. I am starting to think I fried something.
pazi88 wrote:Also does the TS so correct voltage readings?
What exactly do you mean by this? If it displays correct reading of the battery voltage? If so, I have not tested this.

Re: PCB for BMW m42/m50/m60 engine

PostPosted:Tue Jul 28, 2020 1:13 pm
by kocene
kocene wrote:
Tue Jul 28, 2020 8:53 am
pazi88 wrote:Do the injector leds work in HW test mode?
I just tested this and unfortunately, they don't. I am starting to think I fried something.
Okay so I had more time to inspect this and it looks like I am not getting power to the ecu??

If I put 12V to the pin 54 on a bench setup AND at the same time switch on the injector test in TunerStudio test mode, they will switch on. This seemed weird at first because I do have spark and everything else seemed to work. So I went to the car to check... And I am truly not getting ANY power the pin 54. :? So I will have to resolve this issue on the car side and will report back!

Re: PCB for BMW m42/m50/m60 engine

PostPosted:Tue Jul 28, 2020 3:30 pm
by pazi88
Make sure that the dme relay circuit works in the speeduino. There is circuit on pcb that activates dme relay when you turn on ignition and the relay provides 12v to the pin54 of the ecu and injectors.

Re: PCB for BMW m42/m50/m60 engine

PostPosted:Wed Jul 29, 2020 9:31 am
by kocene
Okay so I AM getting power to the pin 54 after all... I was measuring the voltage on the harness with the ecu removed and therefore the main relay circuit was not complete... Nevermind.

I decided to try to open the injectors with the HW test mode (fuel pump relay removed) and they do open. I can hear them click and also the leds turn on as they should. So maybe its software related? I am thinking about getting another Arduino board just to be sure.

Re: PCB for BMW m42/m50/m60 engine

PostPosted:Fri Jul 31, 2020 5:59 pm
by kocene
kocene wrote:
Wed Jul 29, 2020 9:31 am
I am thinking about getting another Arduino board just to be sure.
Got a new board, loaded up the newest FW and the engine started right up :)

Re: PCB for BMW m42/m50/m60 engine

PostPosted:Fri Aug 21, 2020 1:00 pm
by Seke
Hello, have you deleted branch for m50tu_seq fw? Or can I use the official fw with the rev2.0 pcb?

https://github.com/pazi88/speeduino/tre ... ential_BMW

Re: PCB for BMW m42/m50/m60 engine

PostPosted:Sun Sep 13, 2020 9:31 am
by Herbon
Hello, im facing similar problem with m50nv, the problem is I put ignition and I got leds on, speeduino power up, but I don't get purgue of the nozzles and fuel pump is constantly on, then I remove vr conditioner and all work as usually, put ignition on, pump 3 seconds and injectors open to purgue. Put back vr, pump on all time...
I tried new vr conditioner, new arduino, and still facing this issue, at the first I did a mistake and soldered Jp24 to 5v... So the car started without conditioner but I assumed I killed something. Also is very strange I get rpm signal without conditioner??? Car is m50nv
Thx for help :shock:

Re: PCB for BMW m42/m50/m60 engine

PostPosted:Sun Sep 13, 2020 11:07 am
by Herbon
I add... I plug USB and car switch off :O I connect Bluetooth and only connects when car on, if off just ignition no connection..

M50nv , Siemens Deka 630cc

PostPosted:Mon Sep 21, 2020 5:46 pm
by bartekms43
Hi every one.

Can someone tell me proper dead times, open time 3.5 bar fuel for siemens deka 630cc FI107961 ?

And when i wanna use closed loop for idle how P I D works , and what max/min dutycycle ? I use 3 wire IVC i setup 98hz.

Thanks

Re: M50nv , Siemens Deka 630cc

PostPosted:Mon Sep 21, 2020 6:57 pm
by pazi88
bartekms43 wrote:
Mon Sep 21, 2020 5:46 pm
Hi every one.

Can someone tell me proper dead times, open time 3.5 bar fuel for siemens deka 630cc FI107961 ?

And when i wanna use closed loop for idle how P I D works , and what max/min dutycycle ? I use 3 wire IVC i setup 98hz.

Thanks
Here are dead times:
https://drive.google.com/file/d/0B2EFGt ... p=drivesdk

Remember to use open time only mode.

Also I don't recommend using closed loop idle control with pwm valve, untill the issues in that are fixed. Open loop mode with idle advance curve works great.