Speeduino is now on Github Sponsors (Rather than Patreon): https://github.com/sponsors/noisymime
Any strange behaviour, crashing issues etc, post them here! Problems compiling the firmware should go in the General support section rather than here
By Marius222
#48684
Hey!

My IAT readings are fine. But CLT stuck on 82c sometimes -17 if I change resistance manually.
0.4.4b (speeduino-202012release)
Car: Ford sierra Pinto engine
Please help! THX
User avatar
By jonbill
#48685
I think mine said 82 until I connected it and calibrated it.
I take it yours is connected, so maybe the wrong board is selected?
User avatar
By jonbill
#48689
yes, I think the arduino pin for it might vary with the speeduino board, so you have to select the right speeduino board in tunerstudio.
By Marius222
#48698
Its all winter project for me. If I see update I take speeduino from car take back home and update. I did not use any other version before. Today was the first start of the car but CLT readings fail. Yesterday I installed speeduino-202012, today started the car. IDK what was the readings before the update :(
User avatar
By jonbill
#48699
No reason to think there's a problem with that firmware, I'm sure others would have spotted if it didn't read the CLT sensor.
I would guess there is a physical connection problem - the sensor is not connected to the arduino pin.

1J and 1Q appear to be jumped at all times (with i[…]

Speeduino ECU compatibility

Speeduino works with any engine. You just need to[…]

Please read the wiki. It seems you don't understa[…]

VVT angle going backwards?

Pretty sure other than MX-5 trigger VVT is still W[…]

Still can't find what you're looking for?